Bug 84841 - Unable to use (arrow) keys in popup panel menu
Unable to use (arrow) keys in popup panel menu
Status: CLOSED UPSTREAM
Product: Red Hat Linux
Classification: Retired
Component: gtk2 (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Owen Taylor
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-02-21 17:38 EST by Fred New
Modified: 2015-01-07 19:03 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-28 12:30:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fred New 2003-02-21 17:38:10 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030206

Description of problem:
When the mouse is sitting in the (default) center of the screen, I am unable to
select any of the items on the "Systems Tools" menu using keys on the keyboard.
 I am forced to use the mouse.

Version-Release number of selected component (if applicable):
gnome-desktop-2.2.0.1-3
gnome-session-2.2.0.2-2
gnome-panel-2.2.0.1-5
metacity-2.4.34-1

How reproducible:
Always

Steps to Reproduce:
1. Leave or put the mouse in the center of the Gnome desktop.
2. Press <Alt><F1>
3. Without using the mouse, try to select System Tools -> Terminal.
    

Actual Results:  For me, when I use the arrow keys, I am unable to select any of
the items on the System Tools menu.  The "right arrow" key doesn't keep the
System Tools menu selected.

If I move the mouse to other places on the desktop, I am often able to select
the desired item, such as Terminal, from the System Tools menu.

Expected Results:  I expected to be able to use keyboard keys (up arrow, down
arrow, right arrow, enter) to select Terminal from the System Tools menu.

Additional info:
Comment 1 Havoc Pennington 2003-02-21 17:56:13 EST
Works for me. What is your screen resolution? does it have to be *exactly* the
middle of the screen or somewhat off is the same?
Comment 2 Fred New 2003-02-21 19:10:54 EST
I'm using an older 14" monitor with 800 x 600.  I can usually get it to do this
if I attempt to use <Alt><F1> immediately after logging in.  (The mouse is
positioned in the middle of the screen at that time, isn't it?)

I've just done some more experimenting and here's a more precise description:

<Alt><F1>  shows the main menu with Sound & Video highlighted and the Sound &
Video submenu is showing.  If you don't get Sound & Video, position the mouse to
the level where you get Sound & Video, then press <Escape> to disappear the menu
and <Alt><F1> to bring it back - the Sound & Video menu should be showing.

Press <down arrow> twice to get the System Tools menu.

Press <right arrow> once to indicate that you want something from the System
Tools menu.  The More System Tools menu appears.

Press <up arrow> with the intention of wrapping around to Traceroute (at the
bottom of the System Tools menu).  INSTEAD, I get back to the Sound & Video menu.

Does that reproduce it for you?
Comment 3 Havoc Pennington 2003-02-21 19:18:44 EST
Yes, I can reproduce it. I had to put the mouse somewhat down from the center 
in order to get sound and video highlighted. That doesn't seem to be the key point 
though, the important thing is to press up arrow while the "More System Tools"
submenu is popped up. If you have the "More System Tools" popped up then system
tools menu gets closed, instead of wrapping around on up arrow.
Comment 4 Fred New 2003-02-21 19:24:15 EST
Try pressing <down arrow> on the last step, too.  For me this also closes System
Tools and brings up Sound & Video again.
Comment 5 Owen Taylor 2003-02-22 13:22:02 EST
Can't reproduce. I'll try again on Monday with my 800x600 resolution
test box.
Comment 6 Owen Taylor 2003-08-11 12:44:12 EDT
See http://bugzilla.gnome.org/show_bug.cgi?id=116012

Note You need to log in before you can comment on or make changes to this bug.