Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 848424 - Acpid doesn't let Kde to show the shutdown confirmation dialog.
Acpid doesn't let Kde to show the shutdown confirmation dialog.
Status: CLOSED DUPLICATE of bug 819547
Product: Fedora
Classification: Fedora
Component: acpid (Show other bugs)
17
i686 Linux
unspecified Severity low
: ---
: ---
Assigned To: Jaroslav Škarvada
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-15 10:39 EDT by addammo
Modified: 2012-08-16 04:04 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-16 03:36:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description addammo 2012-08-15 10:39:04 EDT
Description of problem: After pressed the power button of my keyboard, systemd shuts down immediately my PC and doesn't let Kde to show the shutdown confirmation dialog.


Version-Release number of selected component (if applicable):
Fedora 17; Systemd version 44-8; Kde 4.8.3.

How reproducible:
Press the power button of the keyboard

Steps to Reproduce:
1. Press the power button of the keyboard
2.
3.
  
Actual results:
The shutdown is immediately.

Expected results:
A shutdown confirmation dialog should appear.

Additional info:
I renamed the file /etc/acpi/actions/power.sh and now the shutdown confirmation dialog appear; systemd doesn't handle that event no longer.
Comment 1 Michal Schmidt 2012-08-15 10:53:23 EDT
> Systemd version 44-8

Before debugging any further, make sure to apply all released updates.

I do not see anything in your bugreport that implicates systemd.
What exactly made you suspect this is systemd's fault?

/etc/acpi/actions/power.sh is a config file of acpid, not systemd.
Comment 2 Michal Schmidt 2012-08-15 10:56:31 EDT
Could you please paste the output of the command:
 loginctl list-sessions
and then:
 loginctl session-status $SESSION_ID_OF_YOUR_KDE_SESSION
Comment 3 addammo 2012-08-15 18:38:21 EDT
(In reply to comment #1)
> > Systemd version 44-8
> 
> Before debugging any further, make sure to apply all released updates.
> 
> I do not see anything in your bugreport that implicates systemd.
> What exactly made you suspect this is systemd's fault?
> 
> /etc/acpi/actions/power.sh is a config file of acpid, not systemd.

You are right, /etc/acpi/actions/power.sh is an acpid's file. I don't know why I thought the issue was related to systemd.
Should I change component and title?
Comment 4 addammo 2012-08-15 18:46:23 EDT
(In reply to comment #2)
> Could you please paste the output of the command:
>  loginctl list-sessions
> and then:
>  loginctl session-status $SESSION_ID_OF_YOUR_KDE_SESSION

loginctl list-sessions

  SESSION        UID USER             SEAT            
         1       1000 marco           seat0

loginctl session-status $SESSION_ID_OF_YOUR_KDE_SESSION

1 - marco (1000)
           Since: Thu, 16 Aug 2012 00:25:46 +0200; 16min ago
          Leader: 646 (kdm)
            Seat: seat0; vc1
         Display: :0
         Service: kdm; type x11; class user
          Active: yes
          CGroup: /user/marco/1
                  ├  646 -:0
                  ├  664 /bin/sh /usr/bin/startkde
                  ├  678 dbus-launch --sh-syntax --exit-with-session
                  ├  679 /bin/dbus-daemon --fork --print-pid 5 --print-address 7 --session
                  ├  752 /usr/libexec/imsettings-daemon
                  ├  799 /usr/bin/ssh-agent /bin/sh -c exec -l /bin/bash -c "/usr/bin/startkde"
                  ├  845 /usr/libexec/kde4/start_kdeinit +kcminit_startup
                  ├  846 kdeinit4: kdeinit4 Running...
                  ├  847 klauncher --fd=9
                  ├  849 kded4
                  ├  851 /usr/libexec/gam_server
                  ├  858 /usr/bin/kglobalaccel
                  ├  860 /usr/bin/kwalletd
                  ├  864 /usr/bin/kactivitymanagerd
                  ├  869 kwrapper4 ksmserver
                  ├  878 ksmserver
                  ├  913 kwin
                  ├  920 /usr/bin/knotify4
                  ├  924 /usr/bin/krunner
                  ├  925 /usr/bin/plasma-desktop
                  ├  929 /usr/bin/akonadi_control
                  ├  931 akonadiserver
                  ├  933 /usr/libexec/mysqld --defaults-file=/home/marco/.local/share/akonadi/mysql.conf --datadir=/home/marco/.local/share/akon...
                  ├  997 /usr/bin/kuiserver
                  ├ 1011 /usr/bin/akonadi_calendarsearch_agent --identifier akonadi_calendarsearch_agent
                  ├ 1012 /usr/bin/akonadi_agent_launcher akonadi_ical_resource akonadi_ical_resource_3
                  ├ 1013 /usr/bin/akonadi_agent_launcher akonadi_kalarm_resource akonadi_kalarm_resource_0
                  ├ 1016 /usr/bin/akonadi_agent_launcher akonadi_kalarm_resource akonadi_kalarm_resource_1
                  ├ 1018 /usr/bin/akonadi_agent_launcher akonadi_kalarm_resource akonadi_kalarm_resource_2
                  ├ 1019 /usr/bin/akonadi_agent_launcher akonadi_maildir_resource akonadi_maildir_resource_4
                  ├ 1020 /usr/bin/akonadi_maildispatcher_agent --identifier akonadi_maildispatcher_agent
                  ├ 1021 /usr/bin/akonadi_mailfilter_agent --identifier akonadi_mailfilter_agent
                  ├ 1028 /usr/bin/akonadi_nepomuk_feeder --identifier akonadi_nepomuk_feeder
                  ├ 1035 /usr/bin/akonadi_nepomuktag_resource --identifier akonadi_nepomuktag_resource
                  ├ 1036 /usr/bin/akonadi_pop3_resource --identifier akonadi_pop3_resource_0
                  ├ 1037 /usr/bin/akonadi_agent_launcher akonadi_vcard_resource akonadi_vcard_resource_2
                  ├ 1067 /usr/bin/kaccess
                  ├ 1077 /usr/bin/nepomukserver
                  ├ 1094 /usr/bin/nepomukservicestub nepomukstorage
                  ├ 1095 /usr/bin/knotes
                  ├ 1098 /usr/bin/abrt-applet
                  ├ 1099 /usr/bin/zeitgeist-datahub
                  ├ 1100 /usr/sbin/restorecond -u
                  ├ 1104 python /usr/bin/printer-applet
                  ├ 1107 /usr/bin/pulseaudio --start --log-target=syslog
                  ├ 1116 /usr/libexec/kde4/polkit-kde-authentication-agent-1
                  ├ 1160 /usr/libexec/dconf-service
                  ├ 1169 /usr/bin/python /usr/bin/zeitgeist-daemon
                  ├ 1170 /usr/bin/korgac --icon korgac
                  ├ 1173 /usr/bin/seapplet
                  ├ 1175 /usr/bin/xsettings-kde
                  ├ 1181 /usr/bin/kmix
                  ├ 1183 /usr/bin/nepomukcontroller
                  ├ 1190 /usr/bin/klipper
                  ├ 1225 /usr/bin/virtuoso-t +foreground +configfile /tmp/virtuoso_ik1094.ini +wait
                  ├ 1299 /usr/bin/nepomukservicestub nepomukfileindexer
                  ├ 1300 /usr/bin/nepomukservicestub nepomukbackupsync
                  ├ 1301 /usr/bin/nepomukservicestub nepomukfilewatch
                  ├ 1306 /usr/bin/nepomukservicestub nepomukqueryservice
                  ├ 1477 /usr/lib/opera/opera https://bugzilla.redhat.com/show_bug.cgi?id=848424
                  ├ 1589 /usr/bin/konsole
                  ├ 1591 /bin/bash
                  └ 1734 loginctl session-status 1
Comment 5 Michal Schmidt 2012-08-16 03:36:02 EDT
The output looks OK - the session is marked as active and "kded4" is listed among its processes (power.sh bases its decision on this).

Knowing that you had not installed the updates (systemd-44-8 is old), I'm going to assume acpid had not been updated either, so bug 819547 was present.

*** This bug has been marked as a duplicate of bug 819547 ***
Comment 6 addammo 2012-08-16 03:49:52 EDT
(In reply to comment #5)
> The output looks OK - the session is marked as active and "kded4" is listed
> among its processes (power.sh bases its decision on this).
> 
> Knowing that you had not installed the updates (systemd-44-8 is old), I'm
> going to assume acpid had not been updated either, so bug 819547 was present.
> 
> *** This bug has been marked as a duplicate of bug 819547 ***

I upgraded acpid to version 2.0.16-4 and this issue is still present.
Comment 7 Jaroslav Škarvada 2012-08-16 04:02:15 EDT
(In reply to comment #6)
> I upgraded acpid to version 2.0.16-4 and this issue is still present.

Could you reproduce with acpid removed?
Comment 8 Jaroslav Škarvada 2012-08-16 04:04:27 EDT
Continuing in bug 819547.

Note You need to log in before you can comment on or make changes to this bug.