Bug 848455 - SELinux is preventing /usr/bin/totem-video-thumbnailer from using the 'dac_override' capabilities.
SELinux is preventing /usr/bin/totem-video-thumbnailer from using the 'dac_ov...
Status: CLOSED DUPLICATE of bug 848452
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:a02dbaa01b695595b30129675f4...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-15 12:17 EDT by Paulo Edson
Modified: 2012-08-15 14:18 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-15 14:18:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paulo Edson 2012-08-15 12:17:08 EDT
libreport version: 2.0.10
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.5.1-1.fc17.i686
time:           Qua 15 Ago 2012 13:16:34 BRT

description:
:SELinux is preventing /usr/bin/totem-video-thumbnailer from using the 'dac_override' capabilities.
:
:*****  Plugin dac_override (91.4 confidence) suggests  ***********************
:
:If você deseja ajudar a identificar se o domínio precisa deste acesso ou se você possui um arquivo com as permissões erradas em seu sistema.
:Then ligue a auditoria completa para obter informações de caminho sobre ofender arquivo e gerar um erro novamente.
:Do
:
:Ligue auditoria completa
:# auditctl -w /etc/shadow -p w
:Tente recriar o AVC. Depois execute
:# ausearch -m avc -ts recent
:Caso você veja a memória PATH verifique a propriedade ou permissões no arquivo e repare-o, caso contrário reporte como um bugzilla.
:
:*****  Plugin catchall (9.59 confidence) suggests  ***************************
:
:If você acredita que o totem-video-thumbnailer deva ser permitido a capacidade de dac_override  por default.
:Then você precisa reportar este como um erro.
:Você pode gerar um módulo de política local para permitir este acesso.
:Do
:permitir este acesso agora executando:
:# grep totem-video-thu /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023
:Target Context                unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023
:Target Objects                 [ capability ]
:Source                        totem-video-thu
:Source Path                   /usr/bin/totem-video-thumbnailer
:Port                          <Desconhecido>
:Host                          (removed)
:Source RPM Packages           totem-3.4.3-1.fc17.i686
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-145.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.5.1-1.fc17.i686 #1 SMP Thu Aug 9
:                              18:12:27 UTC 2012 i686 i686
:Alert Count                   63
:First Seen                    2012-08-10 14:15:57 BRT
:Last Seen                     2012-08-13 13:45:30 BRT
:Local ID                      2f0d3331-ca80-4a57-a5fe-74c076e029ab
:
:Raw Audit Messages
:type=AVC msg=audit(1344876330.903:226): avc:  denied  { dac_override } for  pid=5768 comm="totem-video-thu" capability=1  scontext=unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023 tcontext=unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023 tclass=capability
:
:
:type=AVC msg=audit(1344876330.903:226): avc:  denied  { dac_read_search } for  pid=5768 comm="totem-video-thu" capability=2  scontext=unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023 tcontext=unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023 tclass=capability
:
:
:type=SYSCALL msg=audit(1344876330.903:226): arch=i386 syscall=access success=no exit=EACCES a0=bfa5ffb8 a1=4 a2=4c34dff4 a3=bfa5ffb8 items=0 ppid=5742 pid=5768 auid=1000 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=1 comm=totem-video-thu exe=/usr/bin/totem-video-thumbnailer subj=unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023 key=(null)
:
:Hash: totem-video-thu,thumb_t,thumb_t,capability,dac_override
:
:audit2allow
:
:#============= thumb_t ==============
:allow thumb_t self:capability { dac_read_search dac_override };
:
:audit2allow -R
:
:#============= thumb_t ==============
:allow thumb_t self:capability { dac_read_search dac_override };
:
Comment 1 Daniel Walsh 2012-08-15 14:18:22 EDT

*** This bug has been marked as a duplicate of bug 848452 ***

Note You need to log in before you can comment on or make changes to this bug.