Bug 848503 - libdir usage in jfreechart build
libdir usage in jfreechart build
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: jfreechart (Show other bugs)
18
All Linux
high Severity high
: ---
: ---
Assigned To: Lubomir Rintel
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-15 15:11 EDT by Roland Grunberg
Modified: 2012-09-17 07:32 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-04 09:58:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Roland Grunberg 2012-08-15 15:11:36 EDT
I noticed that jfreechart is failing to build on f18, and f19 due to the prevention of noarch packages from correctly resolving %{_libdir}.

It should be possible to use build-classpath as described in https://fedorahosted.org/fpc/ticket/203#comment:15 .
Comment 1 Severin Gehwolf 2012-08-15 15:40:08 EDT
Thanks for the heads-up, Roland. I'll see to it that this gets changed.
Comment 2 Roland Grunberg 2012-08-16 15:53:36 EDT
This has been fixed in jfreechart-1.0.14-3.
Comment 3 Severin Gehwolf 2012-09-04 09:58:45 EDT
Closing since this has been fixed.
Comment 4 Lubomir Rintel 2012-09-17 07:32:27 EDT
Thanks a lot!

I've approved your ACLs and remove myself from package, since I'm no longer willing to deal with Java stuff. I'd be thankful if you could take the package.

Note You need to log in before you can comment on or make changes to this bug.