Bug 84851 - joystick driver requires a button to detect
Summary: joystick driver requires a button to detect
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: joystick
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-22 03:08 UTC by corey
Modified: 2015-01-04 22:02 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-11-27 23:24:07 UTC


Attachments (Terms of Use)

Description corey 2003-02-22 03:08:11 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 
1.0.3705)

Description of problem:
The joystick driver, generic, found in joydev.c (/drivers/input/joydev.c) looks 
for both axis and button in the connect function before it accepts the device.

Many joysticks, OEM and Pedals, do not have buttons and some have even resorted 
to putting fake button circuits on the chip which mess things up sometimes.

I made a personal fix for this, but it seems to be a large need as a whole.  I 
used a usb joystick for this project.

Corey
Applied Research Associates

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. modprobe joydev
2. cat /dev/input/js0
3.
    

Actual Results:  device not found

Expected Results:  opens and displays characters from joystick device.

Additional info:

This exists on the joystick driver included in the lastest kernels.

Comment 1 corey 2004-11-27 23:42:15 UTC
I'm fairly certain the 2.6 joystick drivers were redone anyway.  I doubt the
same kind of situation exists.

corey


Note You need to log in before you can comment on or make changes to this bug.