Bug 848517 - Screen locking seems completely broken in current Fedora 18
Screen locking seems completely broken in current Fedora 18
Product: Fedora
Classification: Fedora
Component: gnome-shell (Show other bugs)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Owen Taylor
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2012-08-15 15:42 EDT by Adam Williamson
Modified: 2013-02-20 15:37 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2012-09-17 19:47:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Adam Williamson 2012-08-15 15:42:27 EDT
Well, not really sure what to say here...I updated to F18 on Monday, and my system just doesn't lock the screen. At all. Ever. I left it on overnight, woke up, no screen lock. The 'Brightness & Lock' preferences say 'Turn screen off when inactive for: 10 minutes', Lock is set to ON, and 'Lock screen after: Screen turns off'. It was locking mostly fine in F17 (sometimes I got the 'blue background and one window instead of unlock dialog' bug, but actual locking/unlocking always worked).
Comment 1 Adam Williamson 2012-08-15 15:42:43 EDT
Comment 2 Adam Williamson 2012-08-16 01:04:48 EDT
With gnome-shell-3.5.5-2.fc18.x86_64 , I get what seems to be the new lock screen design - a big date/time in the centre with a couple of little grey triangles at the bottom (this is a dual screen setup), which appear to be draggable, though this isn't at all intuitive.

When I drag the whole screen upwards, I get a grey background and nothing. No unlock dialog. Typing my password blind doesn't seem to achieve anything. I have to go to a console, kill gnome-shell, and re-run it to get back to a usable desktop.
Comment 3 Robert Knight 2012-09-05 12:21:46 EDT
I've found that the ESC key will get me to the password prompt.  However, it crashes X when I enter the password.  So far, the only way that I've found back is to restart gdm.
Comment 4 Hans de Goede 2012-09-08 10:26:53 EDT
The new lock screen seems to mostly work for me, except when an app has the keyboard grabbed
when the lock kicks in, I've filed a separate bug to track this: bug 855523.
Comment 5 Robert Knight 2012-09-11 09:10:12 EDT
Problem persists in Alpha RC2.
Comment 6 Adam Williamson 2012-09-17 19:47:32 EDT
so, the bug in the original description has gone. comment #3 is https://bugzilla.redhat.com/show_bug.cgi?id=856256 by the sounds of it. comment #2 at the time was likely caused by using startx. I'm still seeing this symptom intermittently, but I've filed that upstream at https://bugzilla.gnome.org/show_bug.cgi?id=684172 . Hans filed a separate bug for his issue. So let's close this one.
Comment 7 Joel Griffiths 2013-02-20 15:26:10 EST
I am experiencing this problem as well. I believe it's tied to mouse control when the screen is locked. I run synergys on the my Fedora box. When my mouse in on another computer at lock time, I end up with the grey screen problem mentioned here. If the mouse in on the Fedora box at lock time, I don't experience the problem. This seem reasonably repeatable (I've lost enough work to it). :) Thanks for your hard work on this. I've disable automatic lock on my Fedora box now. I don't believe this occurs with manual locks.
Comment 8 Adam Williamson 2013-02-20 15:37:18 EST
That sounds like a rather different situation. I don't use synergy or anything like it. So I think yours may be something different caused by the use of synergy, that you should file separately.

Note You need to log in before you can comment on or make changes to this bug.