Bug 848534 - Use the Real Subscription Manager Icons, with PNGs, not one SVG
Use the Real Subscription Manager Icons, with PNGs, not one SVG
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity unspecified
: beta
: 5.9
Assigned To: Bryan Kearney
Entitlement Bugs
:
Depends On:
Blocks: 771748 827225
  Show dependency treegraph
 
Reported: 2012-08-15 16:30 EDT by Matt Reid
Modified: 2013-01-07 22:59 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 22:59:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Missing Needle (94.89 KB, image/png)
2012-08-15 16:36 EDT, Matt Reid
no flags Details
Runs outside of icon (169.45 KB, image/png)
2012-08-15 16:36 EDT, Matt Reid
no flags Details
16x16 icon with background color (4.25 KB, image/png)
2012-08-27 17:20 EDT, Matt Reid
no flags Details
Updated Icon with no background color (4.78 KB, image/png)
2012-08-28 10:53 EDT, Matt Reid
no flags Details
icons good (109.67 KB, image/png)
2012-09-20 10:04 EDT, J.C. Molet
no flags Details

  None (edit)
Description Matt Reid 2012-08-15 16:30:21 EDT
Turns out we shouldn't be using an svg icon, much less the same icon for all sizes. The built in svg library is a bit wonky*, especially as you get to older versions, so we need to switch over to fixed size PNGs instead. Tracked down our real icons with some help from others and fixed the 16x16 size to not be clipped up top.

https://engineering.redhat.com/trac/subscription-manager/attachment/wiki/GUIRedesign/SubMan-icons.zip

That includes our actual source, and pngs for 16x16, 22x22, 24x24, 32x32, and 48x48.

There may be some package wizardry needed to ensure the icons end up where they need to be, I think jbowes knows what to do.

* - this accounts for the missing dial and text when displaying it in RHEL 5.x and the text that runs outside the image in RHEL 6.x/Fedora.
Comment 1 Matt Reid 2012-08-15 16:36:04 EDT
Created attachment 604692 [details]
Missing Needle
Comment 2 Matt Reid 2012-08-15 16:36:32 EDT
Created attachment 604693 [details]
Runs outside of icon
Comment 3 Matt Reid 2012-08-20 17:01:45 EDT
I screwed up the 16x16 PNG in the first version. It still had the gray baseplate in the background.

New, clean version is included in the updated zip:
https://engineering.redhat.com/trac/subscription-manager/attachment/wiki/GUIRedesign/Sub-Man-icons.zip
Comment 4 Matt Reid 2012-08-21 11:45:59 EDT
If anyone is powerful enough to delete the first zip file, I would be appreciative. I was trying to overwrite and replace it, but I had an errant hyphen and now we have two zip files up on trac.
Comment 5 Bryan Kearney 2012-08-24 10:14:29 EDT
fixed in master at cbe8fbacadc409041f8c74fa18ef3287aa5dfcc3.
Comment 6 RHEL Product and Program Management 2012-08-24 10:18:44 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 7 Matt Reid 2012-08-27 17:20:12 EDT
Created attachment 607347 [details]
16x16 icon with background color

Based on the rpms I installed today*, we're using the wrong 16x16 icon. I see a background on the icon.

We should be using the icon out of this zip - https://engineering.redhat.com/trac/subscription-manager/attachment/wiki/GUIRedesign/Sub-Man-icons.zip

the version in there has a transparent background.

I can't delete the other zip off trac...

* - I used rpms from http://hudson.rhq.lab.eng.bos.redhat.com:8080/hudson/view/Entitlement/job/subscription-manager.el5/1935/
Comment 8 Bryan Kearney 2012-08-28 09:57:50 EDT
in master at dc0fdddd62682f61a3f7b0b7f42420e9567554e2
Comment 9 Matt Reid 2012-08-28 10:53:14 EDT
Created attachment 607629 [details]
Updated Icon with no background color

16x16 icon looks great now.

Minor issue, but it looks like the dialogs we spawn haven't had their icon location updated, and are back to showing the default generic window icon. It'd be nice if those could be mapped to the new png.

Dialogs like:
System Preferences
About
Import Cert
System Facts
Configure Proxy
System Registration
Comment 11 Matt Reid 2012-09-06 14:48:12 EDT
Opened a BZ about comment 9 for 6.4 - 855050.
Comment 12 J.C. Molet 2012-09-20 10:04:31 EDT
Created attachment 614935 [details]
icons good

Testing in latest brew:

  subscription-manager-gui.x86_64 0:1.0.18-1.el5                                

Looks like the icons are now the updated ones and the backgrounds to them are transparent.

Additionally they are now updated to png and are at these locations:

/usr/share/icons/hicolor/16x16/apps/subscription-manager.png
/usr/share/icons/hicolor/22x22/apps/subscription-manager.png
/usr/share/icons/hicolor/24x24/apps/subscription-manager.png
/usr/share/icons/hicolor/32x32/apps/subscription-manager.png
/usr/share/icons/hicolor/48x48/apps/subscription-manager.png

Marking VERIFIED.
Comment 14 errata-xmlrpc 2013-01-07 22:59:06 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0033.html

Note You need to log in before you can comment on or make changes to this bug.