Bug 848564 - System group limit of -1 is accepted
System group limit of -1 is accepted
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.0.0
Unspecified Unspecified
low Severity medium (vote)
: Unspecified
: --
Assigned To: Walden Raines
Sachin Ghai
http://projects.theforeman.org/issues...
: TestBlocker, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-15 17:25 EDT by Jeff Weiss
Modified: 2016-04-22 11:34 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-02 10:05:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
walden: needinfo+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 5163 None None None 2016-04-22 11:34 EDT

  None (edit)
Description Jeff Weiss 2012-08-15 17:25:52 EDT
Description of problem:


Version-Release number of selected component (if applicable):
Katello Version: 1.1.4-1.git.74.4bc9528.el6_3

How reproducible:


Steps to Reproduce:
1. Create a system group
2. Select it
3. change the Limit from unlimited to -1
  
Actual results:
System group updated

Expected results:
Error notification like "System group limit must be positive integer". 

Additional info:
already automated.
Comment 1 Lukas Zapletal 2012-08-17 09:38:53 EDT
I will add javascript check for browsers without HTML5 "spinner" support.
Comment 3 Lukas Zapletal 2012-09-10 03:43:19 EDT
Triage note: Re-targeting to CFSE 2.0, low impact.
Comment 5 Lukas Zapletal 2014-03-12 06:14:19 EDT
I am not sure how much the UI has changed, this might be still relevant.
Comment 6 Walden Raines 2014-04-09 18:02:35 EDT
Note that you now have to enter -2 instead of -1 (as -1 represents unlimited) but this is still valid.
Comment 7 Walden Raines 2014-06-03 11:09:33 EDT
PR: https://github.com/Katello/katello/pull/4203
Comment 8 Bryan Kearney 2014-06-04 08:51:09 EDT
Connecting redmine issue http://projects.theforeman.org/issues/5163 from this bug
Comment 9 Bryan Kearney 2014-06-04 08:55:34 EDT
Connecting redmine issue http://projects.theforeman.org/issues/5163 from this bug
Comment 10 Walden Raines 2014-06-04 09:17:19 EDT
commit ca4b35e3ab1f69a8508664ec7e931d6cada22344
Merge: 5dec326 f10db47
Author: Walden Raines <walden@redhat.com>
Date:   Wed Jun 4 09:16:29 2014 -0400

    Merge pull request #4203 from waldenraines/5163
    
    Fixes #5163/BZ848564 - ensure limited host groups have >= 1 hosts.

commit f10db471b33b86cf15c03af0889a3fca85dec4be
Author: Walden Raines <walden@redhat.com>
Date:   Tue Jun 3 11:06:34 2014 -0400

    Fixes #5163/BZ848564 - ensure limited host groups have >= 1 hosts.
Comment 12 Sachin Ghai 2014-06-05 02:55:30 EDT
Verified with sat6 beta snap8 (Satellite-6.0.3-RHEL-6-20140604.0)


So here is what I've verified.

- I created a host collection ( system-group renamed to host collection) with "unlimited" content-host limit

- And I tried to update the limit with some -ve value. If I set limit to any -ve value except -1 then, UI raises validation error and It is expected.

But If I update the limit with "-1", as soon as I type "-1", the text box closes and points to "unlimited" checkbox. So I'm assuming "-1" still an accepted value to tick the "unlimited" checkbox ? Please confirm.
Comment 13 Walden Raines 2014-06-05 08:47:11 EDT
(In reply to Sachin Ghai from comment #12)
> But If I update the limit with "-1", as soon as I type "-1", the text box
> closes and points to "unlimited" checkbox. So I'm assuming "-1" still an
> accepted value to tick the "unlimited" checkbox ? Please confirm.

Can you please file a new bug for the update issue and I'll fix that one as well?
Comment 14 Sachin Ghai 2014-06-05 09:45:28 EDT
sure..thanks.

Moving this bz to verified since if I set the limit to -1 on host-collection creation, the value is validated and higligted in red. So it appears UI doesn't allow -ve value on creation.

However this issue appears on update so will log seperate issue for that.
Comment 15 Bryan Kearney 2014-07-02 10:05:32 EDT
This was delivered with 6.0.3, which is the Satellite 6 Beta.

Note You need to log in before you can comment on or make changes to this bug.