Bug 848605 - Internal compiler errors building pcl on x86_64
Internal compiler errors building pcl on x86_64
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jakub Jelinek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-15 20:59 EDT by Rich Mattes
Modified: 2012-08-20 20:56 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-20 20:56:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rich Mattes 2012-08-15 20:59:45 EDT
Description of problem:
gcc crashes with segfaults at various points the pcl package on rawhide.  It's happened twice tonight on koji:

https://koji.fedoraproject.org/koji/taskinfo?taskID=4394507
https://koji.fedoraproject.org/koji/taskinfo?taskID=4394313

Version-Release number of selected component (if applicable):
gcc-4.7.1-7.fc19.x86_64

How reproducible:
I can reproduce a crash on my machine pretty consistently.  

Steps to Reproduce:
1. Download pcl sources from fedpkg
2. Rebuild x86_64 in mock a few times
3. Crashes happen intermittently, which is annoying...
  
Actual results:
segfault

Expected results:
build completes

Additional info:
I thought this was some kind of memory corruption error on my end when building large heavily templated packages, but once it started happening on koji I submitted
Comment 1 Jakub Jelinek 2012-08-16 03:22:50 EDT
c++: internal compiler error: Killed (program cc1plus)
means the kernel decided to kill cc1plus, supposedly because it run out of memory.  Generally that is not a gcc bug, unless it eats too much memory compared to what it is compiling.  If it is large heavily templated source, some memory consumption must be expected...  Might be that there is some build box without enough memory, or that you are building the package with make -jN and several large compilations happen at the same time.
Comment 2 Rich Mattes 2012-08-20 20:56:55 EDT
Thanks for the info Jakub.  I disabled parallel make and the build completed without error.  I'll go ahead and close this bug.

Note You need to log in before you can comment on or make changes to this bug.