Bug 848612 - findbugs wrapper script is broken
findbugs wrapper script is broken
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: findbugs (Show other bugs)
17
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Richard Fearn
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-15 22:02 EDT by Glen Kaukola
Modified: 2012-09-17 19:51 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-02 20:48:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Glen Kaukola 2012-08-15 22:02:49 EDT
Description of problem:
When I try and run findbugs, I get the following error:

/bin/findbugs: line 37: cd: /bin/../share/findbugs: No such file or directory
The path ,
which is where I think FindBugs is located,
does not seem to be a directory.

So, the whole /bin /usr/bin consolidation has broken findbugs.  I'd imagine a symlink from /share to /usr/share would fix things.  That or fix up the script.

Version-Release number of selected component (if applicable):
findbugs-1.3.9-8.fc17.noarch

How reproducible:
Always
Comment 1 Richard Fearn 2012-08-16 04:29:29 EDT
Could you try findbugs-1.3.9-11.fc17 from updates-testing? This is the update:

https://admin.fedoraproject.org/updates/findbugs-1.3.9-11.fc17

This was to fix another problem I saw that resulted in a ClassNotFoundException - but I'm wondering if it will fix your problem, too.

(The -11 package runs OK on my F17 system, but I will look into this more in the next couple of days. I imagine it might depend on the value of PATH.)
Comment 2 Richard Fearn 2012-08-16 15:06:21 EDT
Yep, this is a PATH issue. By logging into xfce my PATH gets changed from

  ...:/bin:/usr/bin

to

  ...:/usr/bin:/bin:...

hence why it works for me.

Another update will be coming soon - in the mean time running it using

  $ /usr/bin/findbugs

should work.
Comment 3 Fedora Update System 2012-08-16 15:55:35 EDT
findbugs-1.3.9-12.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/findbugs-1.3.9-12.fc17
Comment 4 Fedora Update System 2012-08-16 15:57:19 EDT
findbugs-1.3.9-12.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/findbugs-1.3.9-12.fc18
Comment 5 Fedora Update System 2012-08-16 17:27:11 EDT
Package findbugs-1.3.9-12.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing findbugs-1.3.9-12.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-12008/findbugs-1.3.9-12.fc18
then log in and leave karma (feedback).
Comment 6 Glen Kaukola 2012-08-16 17:38:56 EDT
findbugs-1.3.9-12.fc17 fixed things.  Thanks a bunch.
Comment 7 Fedora Update System 2012-09-02 20:48:01 EDT
findbugs-1.3.9-12.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2012-09-17 19:51:04 EDT
findbugs-1.3.9-12.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.