Bug 84863 - phoebe GNOME terminal settings crash Red Hat 8.0 GNOME terminal
phoebe GNOME terminal settings crash Red Hat 8.0 GNOME terminal
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: fontconfig (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Owen Taylor
: Triaged
Depends On:
Blocks: 79578
  Show dependency treegraph
 
Reported: 2003-02-22 06:40 EST by Paul Jenner
Modified: 2007-04-18 12:51 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-12 17:22:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Jenner 2003-02-22 06:40:24 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020830

Description of problem:
Not sure if you want a place-holder bug under phoebe for this since people
should be able to use Red Hat 8.1 and Red Hat 8.0 with a shared home directory.

It appears that after running GNOME terminal under phoebe 3 with no changed
settings, going back and running GNOME terminal under Red Hat 8.0 leads to crash
described in upstream bugzilla:

http://bugzilla.gnome.org/show_bug.cgi?id=105408

I'll attempt to reproduce this again after clearing settings.

Steps to Reproduce:
1. share home directory with phoebe 3 and Red Hat 8.0
2. run GNOME terminal under Red Hat 8.0 fine
3. run GNOME terminal under phoebe 3 fine
4. try to run GNOME terminal under Red Hat 8.0 again

Actual Results:
It crashes on start after logging "failed to load default Xft font"

Expected Results:
The two GNOME terminal versions should run with a shared home directory.
Comment 1 Havoc Pennington 2003-02-22 10:26:25 EST
Owen, Nalin: can you think of any reason why Xft could not load any fallback 
font here?
Comment 2 Paul Jenner 2003-02-22 11:26:32 EST
I will post the backtrace from bug-buddy if useful. Running under strace, the
useful bit appears to be:

write(2, "\n** (gnome-terminal:1998): WARNI"..., 281
** (gnome-terminal:1998): WARNING **: Failed to load Xft font pattern
".fulldir-10:slant=0:weight=100:pixelsize=13.3333:antialias=True:hintstyle=2:hinting=True:verticallayout=False:autohint=False:globaladvance=True:dpi=96:rgba=0:scale=1:lang=en-GB",
falling back to default font.
) = 281
open("/usr/share/fonts/afms/adobe", O_RDONLY) = 14
fcntl64(14, F_SETFD, FD_CLOEXEC)        = 0
fstat64(14, {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
mmap2(NULL, 4096, PROT_READ, MAP_PRIVATE, 14, 0) = -1 ENODEV (No such device)
close(14)                               = 0
getpid()                                = 1998
write(2, "\n** (gnome-terminal:1998): WARNI"..., 72
** (gnome-terminal:1998): WARNING **: Failed to load default Xft font.
) = 72
--- SIGSEGV (Segmentation fault) ---
write(3, "\22\0\7\0\3\0\340\1\347\0\0\0\4\0\0\0 I\5\0\1\0\0\0\3\0"..., 64) = 64
read(3, 0xbfffea10, 32)                 = -1 EAGAIN (Resource temporarily
unavailable)
select(4, [3], NULL, NULL, NULL)        = 1 (in [3])
read(3, "\34\243\314\0\3\0\340\1\347\0\0\0\17\227W\206\0\0\0\0\17"..., 32) = 32
read(3, "\1\1\320\0\0\0\0\0\16\0`\1\0\0\0\0\4\0\0\0\0\0\0\0\260"..., 32) = 32
fork()                                  = 1999
wait4(1999, [WIFEXITED(s) && WEXITSTATUS(s) == 0], 0, NULL) = 1999
--- SIGCHLD (Child exited) ---
sigreturn()                             = ? (mask now [SEGV RTMIN])
_exit(1)                                = ?

As noted, I am still trying to reproduce this down to an exact test case with a
new user with no settings.
Comment 3 Paul Jenner 2003-02-22 11:43:04 EST
Ok - narrowed this down to the following test case:

1) create new user under Red Hat 8.0
2) login to GNOME as the user under Red Hat 8.0, run GNOME terminal OK, logout
4) login to GNOME as the user under phoebe 3 then logout immediately
5) login to GNOME as the user under Red Hat 8.0 and run GNOME terminal again

It segfaults after the Xft font problem above. No non-default or changed
settings, no need to ever run GNOME terminal under phoebe to trigger this. Just
having logged into phoebe 3 GNOME is incompatible with Red Hat 8.0 GNOME terminal.
Comment 4 Owen Taylor 2003-02-22 13:24:54 EST
OK, this looks like the change I made to to add .fulldir to ~/.fonts.conf
to fix caching to work properly. Keith has a different patch that
(ab)uses the timestamp field to try and handle the same thing, though
I don't really trust it.

I'll look at that version again.
Comment 5 Owen Taylor 2003-06-12 17:22:59 EDT
This was fixed prior to Red Hat 9

Note You need to log in before you can comment on or make changes to this bug.