Bug 848636 - Default rhlogin isn't shown in help info of "rhc domain"
Default rhlogin isn't shown in help info of "rhc domain"
Status: CLOSED WONTFIX
Product: OpenShift Origin
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
2.x
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Clayton Coleman
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-16 01:39 EDT by jizhao
Modified: 2015-05-14 22:03 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-16 10:49:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jizhao 2012-08-16 01:39:17 EDT
Description of problem:
Run 'rhc help domain -h', and the default rhlogin isn't shown in the help info.

Version-Release number of selected component (if applicable):
rhc-0.97.7-1.el6_3.noarch

How reproducible:
Always

Steps to Reproduce:
1.$ rhc help domain -d
2.$ rhc help domain -d --config my.conf
3.
  
Actual results:
  -l|--rhlogin login        Red Hat login (RedHat Network or OpenShift)


Expected results:
  -l|--rhlogin login        Red Hat login (RHN or OpenShift login) (Default: jizhao+1@redhat.com)


Additional info:
rhc client can successfully get default rhlogin from the conf file and use it as the value of --rhlogin parameter.
Comment 1 Clayton Coleman 2012-08-16 10:49:10 EDT
We've removed the display of the default here because it may require remote calls in some cases.  We may in the future add a way to get your account info from the CLI which would solve this same case.

Not knowing which user you are signed in as is an infrequent case.

Note You need to log in before you can comment on or make changes to this bug.