This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 848659 - fop: non-free ICM color profile included
fop: non-free ICM color profile included
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: fop (Show other bugs)
19
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Ruediger Landmann
Fedora Extras Quality Assurance
:
Depends On:
Blocks: FE-Legal 854316
  Show dependency treegraph
 
Reported: 2012-08-16 03:09 EDT by Mikolaj Izdebski
Modified: 2013-04-20 15:34 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-04-20 15:34:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
proposed patch (6.83 KB, patch)
2013-04-15 08:39 EDT, Michal Srb
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Apache Bugzilla 52704 None None None Never
Debian BTS 657281 None None None Never
Apache JIRA LEGAL-131 None None None Never

  None (edit)
Description Mikolaj Izdebski 2012-08-16 03:09:51 EDT
Description of problem:
fop includes non-free elements. Quoting from
./fop-1.0/src/java/org/apache/fop/pdf/sRGB Color Space Profile.icm.LICENSE.txt:

> Copyright (c) 1998 Hewlett-Packard Company
>
> To anyone who acknowledges that the file "sRGB Color Space Profile.icm" 
> is provided "AS IS" WITH NO EXPRESS OR IMPLIED WARRANTY:
> permission to use, copy and distribute this file for any purpose is hereby 
> granted without fee, provided that the file is not changed including the HP 
> copyright notice tag, and that the name of Hewlett-Packard Company not be 
> used in advertising or publicity pertaining to distribution of the software 
> without specific, written prior permission.  Hewlett-Packard Company makes 
> no representations about the suitability of this software for any purpose.

This license is non-free because it doesn't allow modification.
Please remove non-free parts from Fedora.

This bug affects all supported or developed Fedora releases, from F16 to F19.
Comment 1 Tom "spot" Callaway 2012-08-16 10:04:47 EDT
Upstream is tracking this issue:
https://issues.apache.org/bugzilla/show_bug.cgi?id=52704
Comment 2 Mikolaj Izdebski 2013-01-28 04:25:29 EST
Upstream hasn't done much about this issue. Moreover, their proposed solutions are unacceptable for Fedora. The first one was adding an exception to ship non-free profile (which they already did in a similar case of pdfbox) or to unbundle the profile from their distribution tarball and let anyone that wants to compile or use fop to download the non-free profile separately.

Because this issue is important I would suggest not to wait for upstream to resolve this, but instead replace non-free color profile with a free one.

There are some free profiles available. Debian ships a collection of zlib-licensed profiles (package icc-profiles-free) and Argyll Color Management System provides color profiles under AGPL.
Comment 3 Michal Srb 2013-04-15 08:39:11 EDT
Created attachment 735886 [details]
proposed patch

This patch replaces non-free color profile with free profile from icc-profiles-openicc package.

It also updates package to the newest upstream version 1.1 (#885471)
Comment 4 Fedora Update System 2013-04-15 12:07:59 EDT
fop-1.1-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/fop-1.1-1.fc19
Comment 5 Fedora Update System 2013-04-16 12:08:12 EDT
Package fop-1.1-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing fop-1.1-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-5777/fop-1.1-1.fc19
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2013-04-20 15:34:57 EDT
fop-1.1-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.