Bug 848662 - antlr: non-free elements included
antlr: non-free elements included
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: antlr (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Milos Jakubicek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-16 03:17 EDT by Mikolaj Izdebski
Modified: 2012-08-18 10:31 EDT (History)
2 users (show)

See Also:
Fixed In Version: antlr-2.7.7-23.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-18 10:31:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Update licenses on two Oracle example files to match upstream (5.60 KB, patch)
2012-08-16 10:23 EDT, Tom "spot" Callaway
no flags Details | Diff

  None (edit)
Description Mikolaj Izdebski 2012-08-16 03:17:08 EDT
Description of problem:
fop includes non-free elements. Quoting from
./antlr-2.7.7/examples/java/unicode.IDENTs/ShowString.java:

> Copyright (c) 1995-1998 Sun Microsystems, Inc. All Rights Reserved.
>
> Permission to use, copy, modify, and distribute this software
> and its documentation for NON-COMMERCIAL purposes and without
> fee is hereby granted provided that this copyright notice
> appears in all copies. Please refer to the file "copyright.html"
> for further important copyright and licensing information.

This license is non-free because it doesn't allow commercial use.
Please remove non-free parts from Fedora.

This bug affects all supported or developed Fedora releases, from F16 to F19.
Comment 1 Tom "spot" Callaway 2012-08-16 10:15:03 EDT
These two files (ShowString.java) and (StreamConverter.java) were relicensed under the BSD license by Oracle in 2008 (or earlier):

http://docs.oracle.com/javase/tutorial/displayCode.html?code=http://docs.oracle.com/javase/tutorial/i18n/text/examples/ShowString.java

http://docs.oracle.com/javase/tutorial/displayCode.html?code=http://docs.oracle.com/javase/tutorial/i18n/text/examples/StreamConverter.java

Thus, these files are actually now Free, even if their license header is out of date. I will make a patch to correct it, apply it in rawhide, and send it upstream.
Comment 2 Milos Jakubicek 2012-08-16 10:18:33 EDT
Tom, thanks, I was about to remove that example. Not sure about sending it upstream, antlr2 has been obsoleted for quite some years, but, well, you can give it a try.
Comment 3 Tom "spot" Callaway 2012-08-16 10:22:55 EDT
Yeah, I just noticed the same thing. I'll just attach the patch here for you to apply to rawhide. :)
Comment 4 Tom "spot" Callaway 2012-08-16 10:23:52 EDT
Created attachment 604954 [details]
Update licenses on two Oracle example files to match upstream
Comment 5 Tom "spot" Callaway 2012-08-16 10:24:43 EDT
Lifting FE-Legal, as this is not a blocker, just something we should fix in rawhide.

Note You need to log in before you can comment on or make changes to this bug.