Bug 848693 - /usr/libexec/sesh is not labelled correctly
Summary: /usr/libexec/sesh is not labelled correctly
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: selinux-policy
Version: 5.9
Hardware: All
OS: Linux
medium
medium
Target Milestone: beta
: ---
Assignee: Miroslav Grepl
QA Contact: Milos Malik
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-08-16 08:40 UTC by Milos Malik
Modified: 2013-01-08 03:33 UTC (History)
3 users (show)

Fixed In Version: selinux-policy-2.4.6-332.el5
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-01-08 03:33:04 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0060 normal SHIPPED_LIVE selinux-policy bug fix and enhancement update 2013-01-08 08:27:19 UTC

Description Milos Malik 2012-08-16 08:40:12 UTC
Description of problem:
SELinux policy believes that sesh is installed in /usr/sbin directory, but it is installed in /usr/libexec directory. Therefore the existing file is labelled incorrectly.

Version-Release number of selected component (if applicable):
selinux-policy-minimum-2.4.6-331.el5
selinux-policy-devel-2.4.6-331.el5
selinux-policy-targeted-2.4.6-331.el5
selinux-policy-2.4.6-331.el5
selinux-policy-strict-2.4.6-331.el5
selinux-policy-mls-2.4.6-331.el5

How reproducible:
always

Steps to Reproduce:
# matchpathcon /usr/sbin/sesh
/usr/sbin/sesh  system_u:object_r:shell_exec_t
# matchpathcon /usr/libexec/sesh
/usr/libexec/sesh       system_u:object_r:bin_t
# rpm -ql sudo | grep sesh
/usr/libexec/sesh
# ls -Z /usr/sbin/sesh
ls: /usr/sbin/sesh: No such file or directory
# 

Actual results:
 * incorrect label

Expected results:
 * correct label

Comment 1 RHEL Product and Program Management 2012-08-16 08:57:13 UTC
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.

Comment 3 Miroslav Grepl 2012-09-04 14:42:47 UTC
Fixed in selinux-policy-2.4.6-332.el5

Comment 8 errata-xmlrpc 2013-01-08 03:33:04 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0060.html


Note You need to log in before you can comment on or make changes to this bug.