Bug 848715 - Get error message like "create_job status:503" when enable Jenkins build on DEV.
Get error message like "create_job status:503" when enable Jenkins build on DEV.
Status: CLOSED DUPLICATE of bug 823720
Product: OpenShift Origin
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Jhon Honce
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-16 05:29 EDT by Mengjiao Gao
Modified: 2015-05-14 18:57 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-16 13:26:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Error msg page when enable jenkins build. (91.92 KB, image/png)
2012-08-16 05:29 EDT, Mengjiao Gao
no flags Details

  None (edit)
Description Mengjiao Gao 2012-08-16 05:29:51 EDT
Created attachment 604844 [details]
Error msg page when enable jenkins build.

Description of problem:
    After I created a application named "py", I tried to "Enable jenkins build" to it , but caughted error mistake: "Cartridge Could not add job "py-build" in jenkins server:create_job status:503 You'll need to correct this error before attemping to embed the Jenkins client again" , as the attachment show.
    If I tried again later by clicked "add jenkins" button in this error page, it will be added successful.
    This issue is probably caused by the too long time to prepare jenkins server.But the error message seems not clear to user. There should be a message to tell user what the problem is and guide user to wait a seconds to try again.

Version-Release number of selected component (if applicable):
devenv_1997

How reproducible:
always

Steps to Reproduce:
1.Create an application.
2.Tried to "Enable jenkins build" to it.
3.
  
Actual results:
Get error message which seems not clear to user. 

Expected results:
It should be added successful or give a more clear message to guide user waiting a minute to try again.

Additional info:
Comment 1 Clayton Coleman 2012-08-16 10:46:20 EDT
This looks like it was introduced by the changes to the Jenkins client - the message and error code needs to be the same as it was before.
Comment 2 Jhon Honce 2012-08-16 13:26:02 EDT

*** This bug has been marked as a duplicate of bug 823720 ***

Note You need to log in before you can comment on or make changes to this bug.