Bug 848729 - 3.0 - Allow VDSM to report logical cores/threads as physical cores.
3.0 - Allow VDSM to report logical cores/threads as physical cores.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: vdsm (Show other bugs)
6.3
All Linux
high Severity high
: rc
: ---
Assigned To: Dan Kenigsberg
Ido Begun
infra
:
Depends On: 848728
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-16 06:05 EDT by Lee Yarwood
Modified: 2013-08-09 01:40 EDT (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
In a previous update VDSM stopped recognizing hyperthreaded CPU cores as multiple separate cores. By default each hyperthreaded CPU core is now instead recognized as a single core. This update adds a configuration setting named "report_host_threads_as_cores". When this value is set to true in the "/etc/vdsm/vdsm.conf" file hyperthreaded CPU cores are again treated as multiple separate CPU cores. Refer to this Red Hat Knowledge Base Solution for further information on the previous change to the default behaviour and the reasons for it: https://access.redhat.com/knowledge/solutions/140343
Story Points: ---
Clone Of: 848728
Environment:
Last Closed: 2012-10-18 12:15:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lee Yarwood 2012-08-16 06:05:30 EDT
+++ This bug was initially created as a clone of Bug #848728 +++

Description of problem:
As a result of bz#781975 and http://gerrit.ovirt.org/1737 VDSM's getVdsCaps call only returns the number of physical cores on a system. We should provide a way for customers to force VDSM to return the total number of physical and logical cores/threads on the host.

Version-Release number of selected component (if applicable):
vdsm-4.9.6-28.0.el6_3

How reproducible:
Always

Steps to Reproduce:
1. vdsClient -s 0 getVdsCaps

  
Actual results:
getVdsCaps returns the number of physical cores on the host.

Expected results:
Given the correct config value getVdsCaps should be able to return both the total number of physical and logical cores/threads on a system.

Additional info:
http://gerrit.ovirt.org/#/c/7097/
Comment 3 Dan Kenigsberg 2012-08-16 07:14:18 EDT
http://gerrit.usersys.redhat.com/1398
Comment 5 Dan Kenigsberg 2012-08-19 04:46:46 EDT
when report_host_threads_as_cores is left in its default "false" value, the number of real host cores is to be reported in cpuCores. When the value is changed to "true", hyperthreads are counted instead.
Comment 7 Barak 2012-08-30 08:46:52 EDT
Patch accepted downstream (http://gerrit.usersys.redhat.com/#change,1398)
Hence moving to MODIFIED.
Comment 14 Ido Begun 2012-10-07 02:25:02 EDT
OK - vdsm-4.9-113.4.el6_3
Comment 16 errata-xmlrpc 2012-10-18 12:15:29 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-1390.html

Note You need to log in before you can comment on or make changes to this bug.