Bug 848733 - Update Django to 1.4.1 on el6
Update Django to 1.4.1 on el6
Status: CLOSED CURRENTRELEASE
Product: Fedora EPEL
Classification: Fedora
Component: Django (Show other bugs)
el6
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthias Runge
Fedora Extras Quality Assurance
:
Depends On: 864481
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-16 06:14 EDT by Massimo Paladin
Modified: 2012-11-06 06:31 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-06 06:31:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Massimo Paladin 2012-08-16 06:14:19 EDT
Hello,

could Django be updated to 1.4.1 on el6?

Is there any problem blocking the update?

Cheers,
-Massimo
Comment 1 Matthias Runge 2012-08-22 14:50:58 EDT
As much as I can understand your wish to update, there are some reasons not to do so:
From django-1.2 to django 1.3 some instructions and features were deprecated, but still worked in 1.3. They have been removed in django-1.4
I currently know at least two applications, which still don't support django-1,4, both used also at fedora infrastructure. Further more, django developer discontinued support for older python-versions. (imho, for django-1.4 is python 2.5 is required.)

EL6 should be a stable distribution. Details regarding updates may be found here:
https://fedoraproject.org/wiki/EPEL/GuidelinesAndPolicies#A_major_version_update

One solution is to create a dedicate django-1.4 package for epel6. Currently, I'm not really decided, what to do.
Comment 2 Matthias Runge 2012-10-10 04:06:06 EDT
OK, I can't update, there are too many blockers. 

So, I created a new request for review for a dedicated Django14 package for EPEL6.
Comment 3 Massimo Paladin 2012-10-10 04:48:56 EDT
Ok, thank you very much.
Comment 4 Matthias Runge 2012-10-10 04:54:18 EDT
Massimo, are you interested in doing a review? Basically, this is derived from the other two (python-)Django packages. So nothing really serious. I'd even trade...
Comment 5 Massimo Paladin 2012-10-10 11:58:52 EDT
Matthias, I can review it, just leave me a couple of days.

You don't need to review one of mine but in case you have spare time I've got one waiting (very basic one), actually someone assigned it to himself but didn't do anything so far: 853124.
Comment 6 Matthias Runge 2012-11-06 06:31:41 EST
since Django14 hit epel6 stable, I'll close this ticket.

Note You need to log in before you can comment on or make changes to this bug.