Bug 848740 - sunrpc Kernel 3.5.1 unable to handle NULL ponter dereference
sunrpc Kernel 3.5.1 unable to handle NULL ponter dereference
Status: CLOSED DUPLICATE of bug 830862
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: nfs-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-16 06:30 EDT by Josep
Modified: 2012-08-16 10:39 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-16 10:39:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Picture of the call trace (3.41 MB, image/jpeg)
2012-08-16 06:30 EDT, Josep
no flags Details

  None (edit)
Description Josep 2012-08-16 06:30:44 EDT
Created attachment 604880 [details]
Picture of the call trace

Description of problem:
System crashes due to a NULL pointer dereference when trying to reboot it.
The faulty address seems to point to the sunrpc module, if I am not mistaken:
IP: [<ffffffffa00f6391>] rpc_create+0x401/0x540 [sunrpc]

Version-Release number of selected component (if applicable):
Linux Kernel 3.5.1 (64 bits)

How reproducible:
I have experienced this twice in the last 5~6 reboots.

Steps to Reproduce:
1. Reboot from GDM login screen
  
Actual results:
System does not reboot, but changing to a text console a BUG report can be seen.

Additional info:
System has recently been PreUpgraded from F16 to F17 (no issues during the upgrade).
There are some NFS mounts and it uses NIS to authenticate too.
(attached a picture of the call trace)
Comment 1 Jeff Layton 2012-08-16 10:31:59 EDT
cc'ing Stanislav since this looks like it might be related to his namespace changes.
Comment 2 Jeff Layton 2012-08-16 10:39:02 EDT
Looks like this is the same problem that Stanislav pushed a patch upsteam for earlier in the week. Closing as a dup.

*** This bug has been marked as a duplicate of bug 830862 ***

Note You need to log in before you can comment on or make changes to this bug.