Bug 848756 - Traceback in firstboot if Red Hat Subscription Management Selected
Traceback in firstboot if Red Hat Subscription Management Selected
Status: CLOSED DUPLICATE of bug 848717
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity high
: beta
: ---
Assigned To: Bryan Kearney
Entitlement Bugs
: Regression
Depends On:
Blocks: rhel59rtt
  Show dependency treegraph
 
Reported: 2012-08-16 07:18 EDT by Marian Ganisin
Modified: 2013-01-10 04:48 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-17 02:49:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marian Ganisin 2012-08-16 07:18:03 EDT
Description of problem:

Firsboot raises following exception in case of attempt to use Red Hat Subscription Management service for online registration.

Traceback (most recent call last):
  File "/usr/share/firstboot/firstbootWindow.py", line 266, in nextClicked
    result = module.apply(self.notebook)
  File "/usr/share/firstboot/modules/rhn_choose_server_gui.py", line 70, in apply
    self.parent.setPage("rhsm_login")
  File "/usr/share/firstboot/firstbootWindow.py", line 176, in setPage
    self.nextPage = self.moduleNameToIndex[modulename][0]
KeyError: 'rhsm_login'

Version-Release number of selected component (if applicable):
firstboot-1.4.27.9-1.el5

python-rhsm-1.0.5-1.el5
subscription-manager-1.0.13-1.el5
subscription-manager-firstboot-1.0.13-1.el5
subscription-manager-gui-1.0.13-1.el5

Actual results:
Unable to subscribe to rhsm due to traceback in firstboot.
Comment 1 Alexander Todorov 2012-08-17 02:49:59 EDT

*** This bug has been marked as a duplicate of bug 848717 ***

Note You need to log in before you can comment on or make changes to this bug.