Bug 848767 - User login filter problem - REST API
User login filter problem - REST API
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-restapi (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Michael Pasternak
Ondra Machacek
infra
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-16 07:30 EDT by Ondra Machacek
Modified: 2016-02-10 14:26 EST (History)
8 users (show)

See Also:
Fixed In Version: si16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 15:00:37 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ondra Machacek 2012-08-16 07:30:28 EDT
Description of problem:

Can't login as a user via REST API.

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. Create a user and assgin it a role which is not SuperUser.
2. Try to connect via REST API with this user.
  
Actual results:
<fault>
    <reason>Operation Failed</reason>
    <detail>query execution failed due to insufficient permissions.</detail>
</fault>

Expected results:
User should connect.

Additional info:
Problem is only with url OVIRTENGINE:PORT/api
For example if I try connect with user who has UserVmManager role and try to
connect with curl:

#$ curl -X GET -u user@domain:pass http://url/api/vms

I get list of vms. So the problems seems to be only with /api

Because if I try to do this command:

#$ curl -X GET -H "Filter: true" -u user@domain:pass http://url/api

I get this error:
<fault>
    <reason>Operation Failed</reason>
    <detail>Entity not found: VdcVersion</detail>
</fault>
Comment 1 Michael Pasternak 2012-08-22 12:20:20 EDT
https://gerrit.eng.lab.tlv.redhat.com/#/c/1453/

Note You need to log in before you can comment on or make changes to this bug.