Bug 848774 - offlineimap-6.5.4 is available
offlineimap-6.5.4 is available
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: offlineimap (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dodji Seketeli
Fedora Extras Quality Assurance
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-16 07:40 EDT by Upstream Release Monitoring
Modified: 2014-01-12 00:04 EST (History)
6 users (show)

See Also:
Fixed In Version: offlineimap-6.5.5-1.fc20
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-12 00:04:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Upstream Release Monitoring 2012-08-16 07:40:11 EDT
Latest upstream release: 6.5.4
Current version in Fedora Rawhide: 6.5.2.1
URL: https://github.com/OfflineIMAP/offlineimap/tags

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring
Comment 1 Fedora Admin XMLRPC Client 2012-11-20 10:03:25 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 2 Darryl L. Pierce 2013-07-01 09:00:08 EDT
This BZ is nearly a year old and the updated version has not been packaged. Can the current package maintainer please push an update? Thank you.
Comment 3 Darryl L. Pierce 2013-08-21 16:19:02 EDT
Dodji, it's been a few weeks now since you said in the mailing list that you'd push an update. Any chance of it happening soon?
Comment 4 Dodji Seketeli 2013-09-24 09:02:46 EDT
Phew, sorry for my long response time.

I have been testing the 6.5.5 release candidate in Rawhide for some time now and it worked for me on several diffent email accounts using Dovecot and Zimbra.

I must confess I am extremely nervous because of the idea of people loosing their email and whatnot.  But Darryl, you are right about pushing :-)  I have thus unleashed the dragon and and built it for Rawhide.  You can get it at http://koji.fedoraproject.org/koji/taskinfo?taskID=5975511, test it, and tell me what you think.

I'll be listening.

Sorry again for the long delay.
Comment 6 Darryl L. Pierce 2013-09-24 10:31:21 EDT
I've tested the 6.5.5 scratch build and it works fine for me. I only had to add the cert_fingerprint configuration option for each account but, otherwise, it's been working fine.
Comment 7 Dodji Seketeli 2013-09-24 12:17:56 EDT
Great.  Do you guys want this to be backported to F20 and F19?

I have no actual plan on this.  I know the policy is to reduce churn, but if F19's and F20 offlineimap is broken for people, maybe we should consider backports.

Otherwise, we can just leave it at that and update the package juste in Rawhide when 6.5.5 is released.
Comment 8 Darryl L. Pierce 2013-09-24 13:04:25 EDT
(In reply to Dodji Seketeli from comment #7)
> Great.  Do you guys want this to be backported to F20 and F19?
> 
> I have no actual plan on this.  I know the policy is to reduce churn, but if
> F19's and F20 offlineimap is broken for people, maybe we should consider
> backports.
> 
> Otherwise, we can just leave it at that and update the package juste in
> Rawhide when 6.5.5 is released.

I would say release for at least Fedora 19+, if not F18. That way current and next get the benefit of the latest release.
Comment 9 Christopher Meng 2013-11-09 02:21:46 EST
No updates for f20 even.
Comment 10 Darryl L. Pierce 2013-11-12 07:14:35 EST
(In reply to Darryl L. Pierce from comment #8)
> (In reply to Dodji Seketeli from comment #7)
> > Great.  Do you guys want this to be backported to F20 and F19?
> > 
> > I have no actual plan on this.  I know the policy is to reduce churn, but if
> > F19's and F20 offlineimap is broken for people, maybe we should consider
> > backports.
> > 
> > Otherwise, we can just leave it at that and update the package juste in
> > Rawhide when 6.5.5 is released.
> 
> I would say release for at least Fedora 19+, if not F18. That way current
> and next get the benefit of the latest release.

Do you plan on EVER providing an update? We appreciate that it's a volunteer activity, but to just never do an update is unacceptable. Please either orphan the package or get a co-maintainer.
Comment 11 Dodji Seketeli 2013-12-01 14:05:59 EST
After a fair time of testing, I have updated the offlineimap package to the upstream 6.5.5-0 upstream release in Rawhide (F21).

As soon as F20 re-open again I'll push 6.5.5-0 there as well, and then in F19.

After that, I'll consider orphaning the package if it appears that I still don't have enough time for this.

In the mean time, If someone wants to step as co-maintainer, you are welcome.

Sorry for the time this took.
Comment 12 Christopher Meng 2014-01-05 00:21:55 EST
Please push 6.5.5 to f19+.
Comment 13 Fedora Update System 2014-01-06 04:58:17 EST
offlineimap-6.5.5-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/offlineimap-6.5.5-1.fc20
Comment 14 Fedora Update System 2014-01-06 05:13:58 EST
offlineimap-6.5.5-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/offlineimap-6.5.5-1.fc19
Comment 15 Fedora Update System 2014-01-07 04:47:23 EST
Package offlineimap-6.5.5-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing offlineimap-6.5.5-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-0344/offlineimap-6.5.5-1.fc20
then log in and leave karma (feedback).
Comment 16 Fedora Update System 2014-01-12 00:04:14 EST
offlineimap-6.5.5-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.