Bug 848790 - Can't use an external monitor with lenovo w520
Can't use an external monitor with lenovo w520
Status: CLOSED DUPLICATE of bug 835648
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau (Show other bugs)
17
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Ben Skeggs
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-16 08:16 EDT by Victor
Modified: 2012-08-21 01:52 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-21 01:52:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Victor 2012-08-16 08:16:26 EDT
Description of problem:
X server cannot detect external monitor (VGA-2 is disconnected). Checked with NVIDIA Optimus and discrete videocards.
Fail to boot with discrete video-card and external VGA boot monitor. Error while booting: 
'[drm] Initialized drm 1.1.0 20060810'

System boots when integrated card is chosen and doesn't boot in the case of 'discrete card'. 



Version-Release number of selected component (if applicable):
xorg-x11-drv-nouveau-0.0.16-37.20120306gitf5d1cd2.fc17.x86_64

How reproducible:
always

Steps to Reproduce:
1.install Fedora 17
2.boot
3.plug external monitor
4.run xrandr
  
Additional info:

$ xrandr 
Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 8192 x 8192
LVDS1 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 344mm x 193mm
   1920x1080      60.0*+   50.0  
   1400x1050      60.0  
   1280x1024      60.0  
   1280x960       60.0  
   1024x768       60.0  
   800x600        60.3     56.2  
   640x480        59.9  
VGA1 disconnected (normal left inverted right x axis y axis)
Comment 1 Ben Skeggs 2012-08-21 01:52:14 EDT
The external monitor not working from the Intel GPU is not a bug, it's expected due to the display not being physically connected to the Intel GPU.

It *should* work in Discrete mode however, and I'm marking this bug as a duplicate of the T520 Discrete mode hang bug.  It's likely the same cause.

*** This bug has been marked as a duplicate of bug 835648 ***

Note You need to log in before you can comment on or make changes to this bug.