Bug 848793 - ovirt-engine-backend [TEXT]: wrong error when trying to attach 2 bootable disks to the same vm simultaneously
ovirt-engine-backend [TEXT]: wrong error when trying to attach 2 bootable dis...
Status: CLOSED DUPLICATE of bug 833900
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
unspecified
x86_64 Linux
medium Severity low
: ---
: 3.1.0
Assigned To: Nobody's working on this, feel free to take it
storage
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-16 08:24 EDT by Dafna Ron
Modified: 2016-02-10 15:04 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-16 08:45:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log (14.95 KB, application/x-xz)
2012-08-16 08:24 EDT, Dafna Ron
no flags Details

  None (edit)
Description Dafna Ron 2012-08-16 08:24:42 EDT
Created attachment 604921 [details]
log

Description of problem:

when trying to attach two bootable disks to a vm we are getting wrong error: 

Error while executing action: Cannot attach Action to Virtual Machine Disk. Same action in progress.


Version-Release number of selected component (if applicable):

si14

How reproducible:

100%

Steps to Reproduce:
1. create 2 bootable disks
2. try to simultaneously attach two bootable disks to the same vm 
3.
  
Actual results:

we are getting a wrong error message 

2012-08-16 15:13:19,879 WARN  [org.ovirt.engine.core.bll.AttachDiskToVmCommand] (pool-4-thread-45) CanDoAction of action AttachDiskToVm failed. Reasons:VAR__ACTION__ATTACH_ACTION_TO,VAR__TYPE__VM_DISK,ACTION_TYPE_FAILED_OBJECT_LOCKED


Expected results:

we should get an error that vm can have only one bootable disk

Additional info: full log
Comment 1 Dafna Ron 2012-08-16 08:45:23 EDT

*** This bug has been marked as a duplicate of bug 833900 ***

Note You need to log in before you can comment on or make changes to this bug.