Bug 848801 - Globally uncaught exception on clicking the link Bundles->Repositories->JBoss Patches
Globally uncaught exception on clicking the link Bundles->Repositories->JBoss...
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: UI (Show other bugs)
JON 3.1.1
Unspecified Unspecified
unspecified Severity low
: ER04
: JON 3.2.0
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On:
Blocks: 851239
  Show dependency treegraph
 
Reported: 2012-08-16 08:43 EDT by Sunil Kondkar
Modified: 2014-01-02 15:38 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 851239 (view as bug list)
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot (60.67 KB, image/png)
2012-08-16 08:43 EDT, Sunil Kondkar
no flags Details
Error_details (2.12 KB, text/plain)
2012-08-16 08:44 EDT, Sunil Kondkar
no flags Details

  None (edit)
Description Sunil Kondkar 2012-08-16 08:43:17 EDT
Description of problem:

Clicking on the link Bundles->Repositories->JBoss Patches displays a globally uncaught exception in UI and message center.

Please find attached the details of error in message center and the screenshot.

There are no errors in server or agent log.

Version-Release number of selected component (if applicable):

Build: Version: 3.1.1.ER2
Build Number: f546515:4eb3f2c
Database: PostgreSQL 8.3.8
Browser: Firefox 10.0.2
Java Version: jre1.7.0_05

How reproducible:

Always

Steps to Reproduce:

1. Login to imanage UI.
2. Navigate to Bundles menu.
3. In the left pane, expand the 'Repositories' section.
4. Click on the link JBoss Patches.
  
Actual results:

UI displays globally uncaught exception.

Expected results:

No error should be displayed

Additional info:

Also reproduced on jdk1.6.0_18.
Comment 1 Sunil Kondkar 2012-08-16 08:43:49 EDT
Created attachment 604924 [details]
Screenshot
Comment 2 Sunil Kondkar 2012-08-16 08:44:27 EDT
Created attachment 604925 [details]
Error_details
Comment 3 John Mazzitelli 2012-08-16 12:57:11 EDT
i see this too. Probably this is the repository that is created by the JBoss CSP server plugin.

FYI: This isn't a 3.1.1. blocker. No one needs to use or even look at that repository tree to get things done (AFAIK). I think it was put in there because at one point there was some idea to use it to navigate and populate the repository from there. Nothing like that was ever done.
Comment 4 Charles Crouch 2012-08-16 16:03:07 EDT
Assigning to Lukas
Where did this repo come from? Was this also in jon300, jon310, I don't recall it being there?
Comment 5 Lukas Krejci 2012-08-17 15:06:59 EDT
This is present in both jon300 and jon310 out of the box.
Comment 6 Lukas Krejci 2012-08-17 15:08:05 EDT
As Mazz said, this is a repo automatically created by the CSP content source to pull the patches to.
Comment 7 Charles Crouch 2012-08-29 12:14:22 EDT
As per 8/20 triage pushing to JON312
Comment 8 mark yarborough 2012-11-20 15:46:02 EST
Per triage with loleary, crouch, mfoley: Move to JBoss ON product, set target release JON 3.2, clear priority (will be subject to further triage in JON 3.2 timeframe).
Comment 9 Larry O'Leary 2012-11-21 19:27:26 EST
Looks like this was fixed upstream as per https://bugzilla.redhat.com/show_bug.cgi?id=851239#c1
Comment 10 Jay Shaughnessy 2013-10-17 12:21:13 EDT
moving to modified as the upstream fix should already be in the JON builds.
Comment 11 Simeon Pinder 2013-10-24 00:10:29 EDT
Moving to ON_QA for testing in the next build.
Comment 12 Sunil Kondkar 2013-10-25 07:43:53 EDT
Verified on Version: 3.2.0.ER4 Build Number: e413566:057b211

The Repository section is not visible on the bundles screen.

Note You need to log in before you can comment on or make changes to this bug.