Bug 848805 - e2fsprogs RPM doesn't track shared library dependency requirements
e2fsprogs RPM doesn't track shared library dependency requirements
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: e2fsprogs (Show other bugs)
17
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Eric Sandeen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-16 08:50 EDT by Brian J. Murrell
Modified: 2012-12-20 10:49 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-20 10:49:04 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian J. Murrell 2012-08-16 08:50:01 EDT
Description of problem:

The packaging of e2fsprogs is not tracking updated dependency requirements in it's required shared libraries.  Let's use libcom_err and the update that occurred between 1.41 and 1.42 as an example.

In e2fsprogs commit 4259052093da329907e255b11bf3e799872828c7 set_com_err_gettext() was added to libcom_err.  The tools in the 1.42 release of e2fsprogs now require this symbol.  However since there is no "Requires: libcom_err >= 1.42" in the FC17 e2fsprogs if one were to simply use rpm -U to upgrade from e2fsprogs-1.41.14-2.fc15.x86_64.rpm (which is in FC16, despite the fc15 tag in it's name) to e2fsprogs-1.42-4.fc17.x86_64.rpm one would get the new e2fsprogs, and e2fsprogs-libs but would not get the newly required libcomm_err and would end up with tools from e2fsck that would fail as they can't find a set_com_err_gettext().
Comment 1 Eric Sandeen 2012-08-16 12:42:33 EDT
Ok, I'll add the explicit depends to keep all subpackages together.  I can't do anything about Gnome3 though ;)
Comment 2 Eric Sandeen 2012-08-16 12:46:54 EDT
I'll add libss as well.  So now e2fsprogs will require:

Requires: e2fsprogs-libs = %{version}-%{release}
Requires: libcom_err = %{version}-%{release}
Requires: libss = %{version}-%{release}

which would keep it all in lockstep.

Sound right to you?
Comment 3 Brian J. Murrell 2012-08-16 12:50:16 EDT
(In reply to comment #1)
> Ok, I'll add the explicit depends to keep all subpackages together.

Cool!

What's interesting is that this seems to be done already for EL6, looking at some recent spec files for it.

> I can't
> do anything about Gnome3 though ;)

I'm not sure anyone can at this point.  :-(  I suppose with enough time and effort nothing is impossible though.
Comment 4 Brian J. Murrell 2012-08-16 12:52:14 EDT
(In reply to comment #2)
> I'll add libss as well.  So now e2fsprogs will require:
> 
> Requires: e2fsprogs-libs = %{version}-%{release}
> Requires: libcom_err = %{version}-%{release}
> Requires: libss = %{version}-%{release}
> 
> which would keep it all in lockstep.
> 
> Sound right to you?

It does, yes.  And moreso, it does what EL6 seems to be doing now/already.
Comment 5 Eric Sandeen 2012-08-16 12:56:30 EDT
Hm, so it does.  Shame on me for not changing Fedora at the same time.
Comment 6 Fedora Update System 2012-08-17 12:23:12 EDT
e2fsprogs-1.42.3-3.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/e2fsprogs-1.42.3-3.fc17
Comment 7 Fedora Update System 2012-08-17 21:27:04 EDT
Package e2fsprogs-1.42.3-3.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing e2fsprogs-1.42.3-3.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-12134/e2fsprogs-1.42.3-3.fc17
then log in and leave karma (feedback).
Comment 8 Michael Schwendt 2012-09-08 17:24:02 EDT
If you do this, why not use %?_isa, too?
https://fedoraproject.org/wiki/Packaging:Guidelines#Requiring_Base_Package
Comment 9 Fedora Update System 2012-12-20 10:49:06 EST
e2fsprogs-1.42.3-3.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.