Bug 848806 - ovirt-engine-backend: when updating disk the changes take several seconds to be updated even when its a simple db update
ovirt-engine-backend: when updating disk the changes take several seconds to ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
unspecified
x86_64 Linux
high Severity medium
: ---
: 3.2.0
Assigned To: Tal Nisan
Dafna Ron
storage
: Regression
Depends On:
Blocks: 915537
  Show dependency treegraph
 
Reported: 2012-08-16 08:55 EDT by Dafna Ron
Modified: 2016-02-10 15:24 EST (History)
10 users (show)

See Also:
Fixed In Version: sf3
Doc Type: Release Note
Doc Text:
Previously, the administration portal took several seconds to reflect changes to a virtual machine's disk properties. Now, the virtual machine's Disks tab is refreshed immediately the disk's properties are edited.
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
log (24.01 KB, application/x-xz)
2012-08-16 08:55 EDT, Dafna Ron
no flags Details

  None (edit)
Description Dafna Ron 2012-08-16 08:55:45 EDT
Created attachment 604928 [details]
log

Description of problem:

when you edit a disk to add bootable/shared/wipe or remove them, the changes take about 5 seconds. 
so if I reopen the disk it seems that the change has not been updated. 
since these are simple db updates they should take milliseconds and not 5 seconds (and I am working with a local db). 
also adding a regression on this since this behaviour did not happen in 3.0

Version-Release number of selected component (if applicable):

si14

How reproducible:

100%

Steps to Reproduce:
1. create a disk and attach it to a vm
2. edit -> add boot tag -> save -> edit (same for wipe and share)
3.
  
Actual results:

it takes the change 5 seconds to be updated 

Expected results:

since these are simple db updates they should not take that long

Additional info: backend log
Comment 6 Tal Nisan 2012-11-26 08:49:01 EST
gerrit.ovirt.org/9467/
Comment 7 Dafna Ron 2013-01-07 12:12:01 EST
verified on sf3
Comment 9 Itamar Heim 2013-06-11 04:45:21 EDT
3.2 has been released
Comment 10 Itamar Heim 2013-06-11 04:45:21 EDT
3.2 has been released
Comment 11 Itamar Heim 2013-06-11 04:45:31 EDT
3.2 has been released
Comment 12 Itamar Heim 2013-06-11 04:51:31 EDT
3.2 has been released
Comment 13 Itamar Heim 2013-06-11 05:22:28 EDT
3.2 has been released

Note You need to log in before you can comment on or make changes to this bug.