Bug 848812 - Logs: Orderby "Provider" is not listing "Provider" details in alphabetical order
Logs: Orderby "Provider" is not listing "Provider" details in alphabetical ...
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.1.0
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Angus Thomas
Rehana
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-16 09:13 EDT by Rehana
Modified: 2012-12-04 10:17 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Uppercase and lowercase strings caused the Logs page to improperly sort provider names. This fix converts the strings to lowercase before sorting. Now the Logs page sorts provider names in alphabetical order correctly.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 10:17:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ss1 (296.58 KB, image/png)
2012-08-16 09:13 EDT, Rehana
no flags Details
ss2 (242.35 KB, image/png)
2012-08-16 09:13 EDT, Rehana
no flags Details

  None (edit)
Description Rehana 2012-08-16 09:13:03 EDT
Created attachment 604933 [details]
ss1

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1.Login to conductor
2.Move to Monitor
3.Click on Logs 
4.Select orderby "Provider"
  
Actual results:
Observed that the list was not arranged by the  alphabetical order of provider name(PFA)

Expected results:
Orderby "provider" name should display the list in alphabetical order

Additional info:
rpm -qa | grep aeolus
rubygem-aeolus-cli-0.7.0-0.20120815230025gitd64d64f.fc16.noarch
aeolus-conductor-0.13.0-0.20120816030008gite8ea044.fc16.noarch
aeolus-configure-2.8.0-0.20120815230023gitbdcd549.fc16.noarch
aeolus-conductor-daemons-0.13.0-0.20120816030008gite8ea044.fc16.noarch
rubygem-aeolus-image-0.6.0-0.20120815230028git25b7466.fc16.noarch
aeolus-conductor-doc-0.13.0-0.20120816030008gite8ea044.fc16.noarch
aeolus-all-0.13.0-0.20120816030008gite8ea044.fc16.noarch
Comment 1 Rehana 2012-08-16 09:13:39 EDT
Created attachment 604934 [details]
ss2
Comment 2 Tzu-Mainn Chen 2012-08-16 09:42:45 EDT
Patch created:

http://lists.fedorahosted.org/pipermail/aeolus-devel/2012-August/012129.html
Comment 3 Matt Wagner 2012-08-29 17:05:37 EDT
Patch ACKed + pushed to master and 1.1

On 1.1:
commit d898fe5d1d535fb8cc72cfb8aea42aa307f94eba
Author: Tzu-Mainn Chen <tzumainn@redhat.com>
Date:   Thu Aug 16 09:41:51 2012 -0400

    BZ 848812 downcase sort strings
    
    Signed-off-by: Matt Wagner <matt.wagner@redhat.com>
    (cherry picked from commit d688bc1247cd1ca2fcdc0f1a4c5872f32799d4d1)
Comment 4 Steve Linabery 2012-09-07 17:58:08 EDT
in build aeolus-conductor-0.13.3-1.el6cf
Comment 6 Rehana 2012-09-20 09:05:20 EDT
verified on 


 rpm -qa | grep aeolus 
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-conductor-daemons-0.13.8-1.el6cf.noarch
rubygem-aeolus-cli-0.7.1-1.el6cf.noarch
aeolus-conductor-doc-0.13.8-1.el6cf.noarch
aeolus-all-0.13.8-1.el6cf.noarch
aeolus-conductor-0.13.8-1.el6cf.noarch
aeolus-configure-2.8.6-1.el6cf.noarch
Comment 8 errata-xmlrpc 2012-12-04 10:17:45 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1516.html

Note You need to log in before you can comment on or make changes to this bug.