Bug 848826 - resource agents Filesystem (and hence pacemaker) does not support glusterfs filesystems
resource agents Filesystem (and hence pacemaker) does not support glusterfs f...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: resource-agents (Show other bugs)
6.5
All Linux
medium Severity low
: rc
: ---
Assigned To: David Vossel
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-16 10:06 EDT by Nigel Metheringham
Modified: 2014-02-27 08:56 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-27 08:56:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch for glusterfs support in Filesystem agent (4.98 KB, application/octet-stream)
2012-08-16 10:06 EDT, Nigel Metheringham
no flags Details

  None (edit)
Description Nigel Metheringham 2012-08-16 10:06:25 EDT
Created attachment 604952 [details]
Patch for glusterfs support in Filesystem agent

Description of problem:

The Filesystem agent does not support the glusterfs filesystem, making
use of a glusterfs filesystem dependancy in a cluster rather more
difficult

Version-Release number of selected component (if applicable):

3.9.2-12

How reproducible:

Any attempt to use the Filesystem agent to manage a glusterfs filesystem
fails when mounting the filesystem - it cannot find the appropriate filesystem
module (because glusterfs actually uses fuse).

A proposed solution patch will be attached to this bug.  The patch was
originally found on the glusterfs mailing list - http://gluster.org/pipermail/gluster-users/2011-July/008276.html - but
has been modified to make it a little more generalised.
Comment 6 Fabio Massimo Di Nitto 2014-02-27 08:56:34 EST
This bug was fixed in a recent rebase of resource-agents code.


commit b937726e35cca0e98c1ba0b438389269907754bc
Author: Marcel Pennewi<C3><9F> <linux-foundation@pennewiss.de>
Date:   Mon Aug 1 18:48:34 2011 +0200

    Medium: Filesystem: add support for glusterfs (lf#2620)
    
    Signed-off-by: Dejan Muhamedagic <dejan@suse.de>

Note You need to log in before you can comment on or make changes to this bug.