Bug 848833 - isnsd runs as initrc_t
isnsd runs as initrc_t
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: selinux-policy (Show other bugs)
7.0
All Linux
unspecified Severity medium
: rc
: ---
Assigned To: Miroslav Grepl
Milos Malik
:
Depends On: nopolicy
Blocks: 848829
  Show dependency treegraph
 
Reported: 2012-08-16 10:18 EDT by Milos Malik
Modified: 2014-06-17 22:14 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 05:59:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milos Malik 2012-08-16 10:18:11 EDT
Description of problem:


Version-Release number of selected component (if applicable):
selinux-policy-minimum-3.10.0-137.el7.noarch
selinux-policy-doc-3.10.0-137.el7.noarch
selinux-policy-3.10.0-137.el7.noarch
selinux-policy-mls-3.10.0-137.el7.noarch
selinux-policy-devel-3.10.0-137.el7.noarch
selinux-policy-targeted-3.10.0-137.el7.noarch
isns-utils-0.91-8.el7.x86_64

How reproducible:
always

Steps to Reproduce:
# run_init service isnsd status
Authenticating root.
Password: 
Redirecting to /bin/systemctl status  isnsd.service
isnsd.service - ISNS Server
	  Loaded: loaded (/usr/lib/systemd/system/isnsd.service; disabled)
	  Active: failed (Result: exit-code) since Thu, 16 Aug 2012 16:16:02 +0200; 11s ago
	 Process: 22685 ExecStart=/usr/sbin/isnsd -f (code=exited, status=1/FAILURE)
	  CGroup: name=systemd:/system/isnsd.service

# run_init service isnsd start
Authenticating root.
Password: 
Redirecting to /bin/systemctl start  isnsd.service
# run_init service isnsd status
Authenticating root.
Password: 
Redirecting to /bin/systemctl status  isnsd.service
isnsd.service - ISNS Server
	  Loaded: loaded (/usr/lib/systemd/system/isnsd.service; disabled)
	  Active: active (running) since Thu, 16 Aug 2012 16:16:23 +0200; 4s ago
	Main PID: 24725 (isnsd)
	  CGroup: name=systemd:/system/isnsd.service
		  └ 24725 /usr/sbin/isnsd -f

# ps -efZ | grep isnsd
system_u:system_r:initrc_t:s0   root     24725     1  0 16:16 ?        00:00:00 /usr/sbin/isnsd -f
unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 root 24800 22186  0 16:16 pts/0 00:00:00 grep --color=auto isnsd
#
  
Actual results:
 * isnsd runs as initrc_t

Expected results:
 * isnsd runs in its own SELinux domain
Comment 1 Daniel Walsh 2012-10-12 16:22:52 EDT
Fixed in selinux-policy-3.11.1-38.el7
Comment 3 Milos Malik 2012-10-30 08:01:36 EDT
Here is the only AVC that appeared in permissive mode:
----
type=SYSCALL msg=audit(10/30/2012 13:00:16.867:2948) : arch=x86_64 syscall=listen success=yes exit=0 a0=0x4 a1=0x80 a2=0x2 a3=0x7fff7c69260c items=0 ppid=1 pid=7252 auid=unset uid=root gid=root euid=root suid=root fsuid=root egid=root sgid=root fsgid=root tty=(none) ses=unset comm=isnsd exe=/usr/sbin/isnsd subj=system_u:system_r:isnsd_t:s0 key=(null) 
type=AVC msg=audit(10/30/2012 13:00:16.867:2948) : avc:  denied  { listen } for  pid=7252 comm=isnsd lport=3205 scontext=system_u:system_r:isnsd_t:s0 tcontext=system_u:system_r:isnsd_t:s0 tclass=tcp_socket 
----
Comment 4 Miroslav Grepl 2012-10-30 08:11:35 EDT
Added to selinux-policy-3.11.1-48.fc18
Comment 7 Miroslav Grepl 2013-06-24 10:15:31 EDT
commit 6d639b0810eb1ad573c8a3c05446f777b94ab8fb
Author: Miroslav Grepl <mgrepl@redhat.com>
Date:   Mon Jun 24 16:13:55 2013 +0200

    Allow isnsd listen on own tcp_socket
Comment 9 Ludek Smid 2014-06-13 05:59:00 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.