Bug 848844 - update Membership label from "Add/Edit Membership" to "Add Membership"
update Membership label from "Add/Edit Membership" to "Add Membership"
Status: NEW
Product: JBoss Enterprise Portal Platform 5
Classification: JBoss
Component: Portal (Show other bugs)
5.2.1.GA
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Default User
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-16 10:52 EDT by Gary Hu
Modified: 2014-07-24 23:18 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Enhancement
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
membership.png (91.87 KB, image/png)
2012-08-16 10:53 EDT, Gary Hu
no flags Details

  None (edit)
Description Gary Hu 2012-08-16 10:52:08 EDT
In the User Management > Membership Management screen, the label says "Add/Edit Membership" but really from that section you can only add users.  Editing is done through the same page above the section in "Action" column in a data table.  

Recommend updating to just "Add Membership" so it's not confusing for end users.
Comment 1 Gary Hu 2012-08-16 10:53:12 EDT
Created attachment 604961 [details]
membership.png
Comment 2 Gary Hu 2012-08-16 10:54:35 EDT
Is it possible to update the label in EPP 5.2.2?
Comment 3 Martin Weiler 2012-08-16 10:58:39 EDT
I don't see why this should be a bug. The lower part of the screen is for *Adding* Membership entries, as well as for *Editing* them. Once you click on the Edit Action in the row of one Membership entry, the fields in the lower part of the screen are filled with the details of that row, ready for editing. To me that label is therefore consistent with the behavior the form provides.
Comment 4 Gary Hu 2012-08-16 11:13:38 EDT
I think the confusing part is when user sees the label "Add/Edit" in the section they expect a button or something for editing is also available in that section. 
But actually, the editing is not in that section. It's in the same page but a different section. 

It seems that it's not as simple as changing the label from "Add/Edit" to "Add" here because both adding and editing are sharing one single section. 

In my opinion, the ideal way is to show "Add" for that section by default, when you click the edit icon it either uses a different section or dynamically change the label "Add" to "Edit" if it uses the same section.

Note You need to log in before you can comment on or make changes to this bug.