Bug 848853 - The resource tree should visually notify when resource pruning has been applied
The resource tree should visually notify when resource pruning has been applied
Status: CLOSED DUPLICATE of bug 849761
Product: JBoss Operations Network
Classification: JBoss
Component: UI (Show other bugs)
JON 3.1.1
All All
unspecified Severity high
: ---
: JON 3.3.0
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On: 879070
Blocks: 849761
  Show dependency treegraph
 
Reported: 2012-08-16 11:18 EDT by Jay Shaughnessy
Modified: 2014-08-22 16:26 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 879070 (view as bug list)
Environment:
Last Closed: 2014-08-22 16:26:58 EDT
Type: Enhancement
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jay Shaughnessy 2012-08-16 11:18:53 EDT
This is related to the work done for bug 847014.

To avoid unbounded resource fetches when building/expanding the resource tree we at times prune the returned resources.

Today we do not indicate to the user that he may not be seeing all of his resources in the tree.

We should give some indication, and possibly provide easy ways to then get to the [possibly pre-filtered] Inventory-Children view for the resource.

UX should be involved in designing the approach.
Comment 1 Jay Shaughnessy 2012-08-16 11:21:40 EDT
Technical note: An idea here is to change the return type of findResourcesByCriteriaBounded to be a composite that includes the List of resources as well as some other Object that provides information about any pruning applied (like Type|Returned#|Total# tuples).

Then that info could help us introduce hooks into the tree.
Comment 2 Charles Crouch 2012-10-08 09:38:14 EDT
We should complete the work which was started in 311 around the navigation tree
Comment 3 mark yarborough 2012-11-20 15:45:45 EST
Per triage with loleary, crouch, mfoley: Move to JBoss ON product, set target release JON 3.2, clear priority (will be subject to further triage in JON 3.2 timeframe).
Comment 4 Larry O'Leary 2013-08-09 11:53:41 EDT
Re-targeted to 3.3 as part of work that needs to be done with bug 849761.
Comment 5 Jay Shaughnessy 2014-08-22 16:26:58 EDT
Setting this as a duplicate of Bug 849761, which is a superset.

*** This bug has been marked as a duplicate of bug 849761 ***

Note You need to log in before you can comment on or make changes to this bug.