Bug 848875 - dom4j: possibly contains non-free documentation
dom4j: possibly contains non-free documentation
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: dom4j (Show other bugs)
18
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Mikolaj Izdebski
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-16 12:30 EDT by Mikolaj Izdebski
Modified: 2012-12-01 04:54 EST (History)
3 users (show)

See Also:
Fixed In Version: 1.6.1-11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-01 04:53:58 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mikolaj Izdebski 2012-08-16 12:30:56 EDT
xml-apis-2.0.2.jar contains LICENSE.dom-documentation.txt, which states:
> W3C® DOCUMENT NOTICE AND LICENSE
> Copyright © 1994-2001 World Wide Web Consortium

This license is not allowed in Fedora, see:
http://fedoraproject.org/wiki/Licensing:Main#Bad_Licenses_2

I'm not sure if this license actually covers any documentation included in binary packages, but the jar file that contains it is removed in %prep.
If there is any non-free documentation, please remove it from Fedora.
Otherwise please remove the license file as it doesn't apply and only causes confusion.
Comment 1 Hans de Goede 2012-08-18 05:10:03 EDT
Thanks for reporting this! I've discussed this with Tom Callaway, and since the files in question are
not actual distributed other then as part of the src.rpm, This is not an issue:

On 08/17/2012 09:32 AM, Hans de Goede wrote:
> Hi Spot,
>
> Someone has brought it to my attention that one of the dependency jars
> bundled with dom4j contains W3C Documentation Licensed files:
> https://bugzilla.redhat.com/show_bug.cgi?id=848875
>
> (sigh java upstreams are terrible with all their bundled jars)
>
> The first thing %prep does is blow these jars away, and the rest
> of the build uses system versions of the jars in question, so the
> files in there are not used at all.
>
> Given that according to:
> http://fedoraproject.org/wiki/Licensing:Main#Bad_Licenses_2
> the problem with the W3C doc license is "Does not permit modification",
> I was wondering if it is necessary to create a cleaned-up sources
> tarbal for dom4j for this, or if things are ok as is?

Nope, this is fine. There is no restriction on redistribution, thus a
"clean" source tarball is not required (although, if you want to do it,
you can).

~tom

###

Closing this as not a bug.
Comment 2 Mikolaj Izdebski 2012-08-20 03:47:56 EDT
I think it still would be better to remove copyright notices and license files that don't apply to any material in SRPM, especially if they are non-free.
Comment 3 Hans de Goede 2012-08-20 04:47:13 EDT
I'm not going to stop you from:

1) Writing a cleanup-sources.sh script to generate a -clean.tar.gz from the original upstream tarbal
2) replace Source0 with a newly generated -clean.tar.gz and add cleanup-sources.sh as Source1
3) commit and build the above for rawhide.

If you don't have commit access to dom4j , feel free to ask for it in pkgdb and I'll grant it.

But I simply don't have the time to do this myself atm.
Comment 4 Mikolaj Izdebski 2012-08-20 04:54:06 EDT
(In reply to comment #3)
> I'm not going to stop you from:

Not having commit right was stopping me.
But I will request it and fix the bug.
Comment 7 Tom "spot" Callaway 2012-08-21 08:28:08 EDT
Not actually a legal blocker, so I'm lifting FE-Legal here, feel free to fix the bug though. :)
Comment 8 Fedora Update System 2012-10-29 12:14:53 EDT
dom4j-1.6.1-11.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/dom4j-1.6.1-11.fc18
Comment 9 Fedora Update System 2012-10-29 14:15:48 EDT
Package dom4j-1.6.1-11.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dom4j-1.6.1-11.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-17165/dom4j-1.6.1-11.fc18
then log in and leave karma (feedback).
Comment 10 Fedora Update System 2012-12-01 04:54:00 EST
dom4j-1.6.1-11.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.