Bug 848885 - rhui-installer should propagate all answers file modifications
rhui-installer should propagate all answers file modifications
Status: CLOSED ERRATA
Product: Red Hat Update Infrastructure for Cloud Providers
Classification: Red Hat
Component: RHUA (Show other bugs)
2.1
Unspecified Unspecified
high Severity unspecified
: ---
: 2.1.1
Assigned To: James Slagle
mkovacik
:
Depends On: 824940
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-16 13:30 EDT by mkovacik
Modified: 2013-02-27 11:59 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Modifications in answers file were not propagated to the configurations files: rhui-tools.conf and pulp.conf. This fix updates rhui_configurator.py, answers.py, and rhua.py. rhui-installer now propagates all answers file modifications.
Story Points: ---
Clone Of: 824940
Environment:
Last Closed: 2013-02-27 11:59:31 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 James Slagle 2012-11-29 15:45:08 EST
commit 42fb6776f661fda0806af41ec7d0476160017cf1

If you unset proxy_server_host, proxy_server_port, proxy_server_username, or proxy_server_password from the answers file and regenerate the rhua configuration rpm and install it, those unset values will now be propagated to /etc/rhui/rhui-tools.conf and /etc/pulp/pulp.conf.
Comment 2 Vitaly Kuznetsov 2013-02-04 09:38:09 EST
[root@rhua ~]# rpm -q rh-rhui-tools
rh-rhui-tools-2.1.15-1.el6_3.noarch

[root@rhua ~]# rhui-installer /etc/rhui/answers.848885 && echo SUCCESS
Generating RHUA configuration RPM
RHUA RPM can be found at [/etc/rhui/confrpm]
Generating CDS bundle for CDS [cds1.example.com]
CDS RPM can be found at [/etc/rhui/confrpm]
SUCCESS
[root@rhua ~]# rpm -U /etc/rhui/confrpm/rhua.example.com-1.1-*.rpm && echo SUCCESS
Updating RHUA Server Configuration
Updating RHUA Repository Authentication Configuration
Updating Apache SSL Configuration
removing persisted tasks
data model in use matches the current version
database migration to version 41 complete
Stopping httpd: [  OK  ]
Stopping Qpid AMQP daemon: [  OK  ]
Stopping mongod: [  OK  ]
Starting mongod: [  OK  ]
Starting Qpid AMQP daemon: [  OK  ]
Starting httpd: [  OK  ]
SUCCESS
[root@rhua ~]# diff -u /etc/rhui/answers /etc/rhui/answers.848885 || echo SUCCESS
--- /etc/rhui/answers	2013-02-04 09:32:22.173298637 -0500
+++ /etc/rhui/answers.848885	2013-02-04 09:35:53.593298637 -0500
@@ -6,9 +6,7 @@
 qpid_nss_db: /etc/rhui/qpid/nss
 [rhua]
 proxy_server_host: proxy.example.com
-proxy_server_port: 3128
 proxy_server_username: rhua
-proxy_server_password: password
 hostname: rhua.example.com
 rpm_name: rhua.example.com
 ssl_cert: /etc/rhui/pem/rhua.example.com.crt
SUCCESS
[root@rhua ~]# Run 'grep -P "^(proxy_port|proxy_pass)" /etc/pulp/pulp.conf /etc/rhui/rhui-tools.conf', got 1 return value
Run 'grep "proxy_url" /etc/pulp/pulp.conf', got 0 return value
Run 'grep "proxy_url" /etc/rhui/rhui-tools.conf', got 0 return value
Run 'grep "proxy_user" /etc/pulp/pulp.conf', got 0 return value
Run 'grep "proxy_user" /etc/rhui/rhui-tools.conf', got 0 return value
Comment 4 errata-xmlrpc 2013-02-27 11:59:31 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0571.html

Note You need to log in before you can comment on or make changes to this bug.