Bug 848891 - [abrt] scap-workbench-0.6.3-1.fc17: openscap_api.py:45:_import_helper:ImportError: /usr/lib64/python2.7/site-packages/_openscap_py.so: undefined symbol: __oscap_reallocf_dbg
[abrt] scap-workbench-0.6.3-1.fc17: openscap_api.py:45:_import_helper:ImportE...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: scap-workbench (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Martin Preisler
Fedora Extras Quality Assurance
abrt_hash:63e0f3c4762d34eccaeeaba1db7...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-16 13:38 EDT by Russell Doty
Modified: 2012-11-27 11:45 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-27 11:45:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Russell Doty 2012-08-16 13:38:03 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
cmdline:        python2 /usr/bin/scap-workbench
comment:        Failure occurs when launching the scap workbench. Program does not start successfully.
executable:     /usr/bin/scap-workbench
kernel:         3.5.1-1.fc17.x86_64
time:           Thu 16 Aug 2012 12:55:03 PM EDT
uid:            1000
username:       Russ.Doty

backtrace:
:openscap_api.py:45:_import_helper:ImportError: /usr/lib64/python2.7/site-packages/_openscap_py.so: undefined symbol: __oscap_reallocf_dbg
:
:Traceback (most recent call last):
:  File "/usr/bin/scap-workbench", line 47, in <module>
:    main()
:  File "/usr/bin/scap-workbench", line 38, in main
:    from scap_workbench.scanner import MainWindow
:  File "/usr/lib/python2.7/site-packages/scap_workbench/scanner/__init__.py", line 32, in <module>
:    from scap_workbench import core
:  File "/usr/lib/python2.7/site-packages/scap_workbench/core/__init__.py", line 40, in <module>
:    import openscap_api as openscap
:  File "/usr/lib64/python2.7/site-packages/openscap_api.py", line 49, in <module>
:    OSCAP = _import_helper()
:  File "/usr/lib64/python2.7/site-packages/openscap_api.py", line 45, in _import_helper
:    _mod = imp.load_module('_openscap_py', fp, pathname, description)
:ImportError: /usr/lib64/python2.7/site-packages/_openscap_py.so: undefined symbol: __oscap_reallocf_dbg
:
:Local variables in innermost frame:
:fp: <closed file '/usr/lib64/python2.7/site-packages/_openscap_py.so', mode 'rb' at 0x18db8a0>
:imp: <module 'imp' (built-in)>
:dirname: <function dirname at 0x7f75d65da500>
:pathname: '/usr/lib64/python2.7/site-packages/_openscap_py.so'
:description: ('.so', 'rb', 3)
Comment 1 Martin Preisler 2012-08-20 05:35:43 EDT
Thanks for reporting, this is a regression in openscap bindings. We are working to get this fixed in the next release.
Comment 2 Russell Doty 2012-08-25 15:00:07 EDT
Launch scap-workbench. Application fails before opening.

Package: scap-workbench-0.6.3-1.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 3 Martin Preisler 2012-08-27 10:43:20 EDT
The issue isn't in scap-workbench itself, it is in openscap bindings.

This particular issue has been fixed in 0.8.4 but there is another one that prevents import of the bindings.

We hope to have all of this fixed with openscap 0.8.5. Sorry for inconveniences.
Comment 4 Fedora Update System 2012-10-29 10:02:22 EDT
openscap-0.9.1-1.fc16,scap-workbench-0.7.0-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/openscap-0.9.1-1.fc16,scap-workbench-0.7.0-1.fc16
Comment 5 Fedora Update System 2012-11-07 20:54:28 EST
openscap-0.9.1-1.fc16, scap-workbench-0.7.0-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.