Bug 848895 - X server bell broken
X server bell broken
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2012-08-16 14:09 EDT by Chris Adams
Modified: 2013-02-13 01:36 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2013-02-06 17:40:47 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Chris Adams 2012-08-16 14:09:46 EDT
I installed F17 on a system and I cannot make the PC speaker work as the X "bell".  This worked fine in F16.

I commented out the snd_pcsp line in /etc/modprobe.d/blacklist.conf, loaded the module, and restarted X.  I am running the XFCE desktop.  I then used "xset b on" and "xset b 100 523 75" to configure the X server bell.  I tried xterm, XFCE's Terminal (with the "hidden" option to enable beeps set), and xkbbell, but none will make a beep.

I know the X server knows how to beep because "xkbbell -force" does indeed beep (this XkbForceBell() instead of just XkbBell()).
Comment 1 Adam Benjamin 2013-02-04 21:26:58 EST
I find it mind-numbing that this hasn't been fixed yet.

I can run "beep" as root and it works, but if I run it as myself it fails.  (Permission denied on /dev/console.  And an ioctl error if I manually change perms on /dev/console to allow all users access.)  And, similar to the original ticket owner, I can run xkbbell and it fails unless I run with -force.

I see a README.fedora as part of the "beep" package that suggests that this problem has been known awhile (the file's date is January 12th, 2012!!)

I know this is pretty archaic stuff as notifications go, but some of us very much rely upon it.  It's making me regret upgrading from F16 to F17.

And in 5 months of this ticket being open, it hasn't even been assigned?  Seriously... if I didn't need to run RHEL for my work, I'd be looking at other distributions. I know it's a minor thing, but it's stuff like this which has end users looking to other distributions.  I mean if we can't even make the console beep...

Let me know if I can aid in testing in any way.  And yes I'm sure pcspkr is loaded (as mentioned, running as root works.)

Comment 2 Peter Hutterer 2013-02-06 01:11:12 EST
what's the output of xkbset q?
Comment 3 Adam Benjamin 2013-02-06 10:52:14 EST
Well, huzzah!  I didn't know about xkbset - I only knew about xset.  Running "xkbset b" enabled the (disabled) audible bell, and all of a sudden I'm back to desired operation.  I'm glad the fix (at least for me) was trivially easy - I just had no idea such a tool existed.  (And I don't see the package in Fedora 16.)

So... a bit disappointing that the "default" changed (and I had no way of knowing I had to look in a new direction) but fabulous that it's a fast and easy change.  (My .xsession just grew by one command - and that's completely acceptable.)

Thanks for your help (and well placed question,) Peter.  I wonder if this will help the original post-er, Chris.

Thanks again,

Comment 4 Peter Hutterer 2013-02-06 17:40:47 EST
Closing as NOTABUG, this is a configuration issue.

Not sure why this would've changed though, this code hasn't moved much in ages. I wonder if the desktop environment is enabling/disabling XKB features.
Comment 5 Chris Adams 2013-02-07 06:48:00 EST
I had been using xset to enable and adjust the bell, and that worked in F16/XFCE.  When I switched to F17/XFCE, it quit working (no error, just no bell).  Using xkbset to enable the bell works.  Hurray for progress...

Note You need to log in before you can comment on or make changes to this bug.