Bug 848906 - rhn-channel fails on a freshly installed rhel6.3 VM
rhn-channel fails on a freshly installed rhel6.3 VM
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: rhn-client-tools (Show other bugs)
6.3
x86_64 Linux
unspecified Severity urgent
: rc
: ---
Assigned To: Milan Zázrivec
Red Hat Satellite QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-16 14:50 EDT by Aldy Hernandez
Modified: 2014-09-29 11:01 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-09-29 11:01:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aldy Hernandez 2012-08-16 14:50:34 EDT
Description of problem:
[root@relcito6 aldyh]# rhn-channel -u rhn-engineering-aldyh -l
Unable to locate SystemId file. Is this system registered?

But system is already registered.  If I try "rhn_register", the GUI responds with "Warning. This system has already been registered...".

On the other hand, if I try rhn-channel -L, I get a different error:

[root@relcito6 aldyh]# rhn-channel -u rhn-engineering-aldyh -L
Password: 
An error has occurred:
<type 'exceptions.TypeError'>
See /var/log/up2date for more information

This is a freshly installed RHEL 6.3 Workstation running on a VM.

I even yum updated my system, to no avail.

Version-Release number of selected component (if applicable):

[root@relcito6 aldyh]# rpm -qf /usr/sbin/rhn-channel
rhn-setup-1.0.0-87.el6.noarch
[root@relcito6 aldyh]# cat /etc/issue
Red Hat Enterprise Linux Workstation release 6.3 (Santiago)
Kernel \r on an \m

How reproducible:
Every time.

Steps to Reproduce:
1. install system
2. rhn-channel ...
3.
  
Actual results:


Expected results:


Additional info:
Comment 2 Milan Zázrivec 2012-08-17 02:35:58 EDT
Couple of questions:

* Does the file /etc/sysconfig/rhn/systemid exist?

* What does /etc/sysconfig/rhn/up2date contain?

* What /var/log/up2date show when you run rhn-channel -L ?
Comment 3 Stephen Herr 2012-09-26 16:06:36 EDT
I am unable to reproduce.

Steps I took:
1) install fresh RHEL 6.3 Workstation in a vm
2) register the system to my Satellite using rhnreg_ks
3) run rhn-channel ...

rhn-channel appears to be working correctly in all cases. Since this has been NEEDINFO for over a month with no response, and we cannot reproduce the issue, I recommend that we close this bug.
Comment 4 Stephen Herr 2012-09-27 09:19:33 EDT
I actually encountered something very similar while doing testing something completely different. I:
1) registered the server to my spacewalk server
2) ran rhn-channel, received error above

Error recorded in /var/log/up2date:
[Thu Sep 27 09:09:23 2012] up2date successfully retrieved authentication token from up2date server
[Thu Sep 27 09:09:24 2012] up2date Updating package profile
[Thu Sep 27 09:12:28 2012] up2date
Traceback (most recent call last):
  File "/sbin/rhn-channel", line 161, in <module>
    main()
  File "/sbin/rhn-channel", line 152, in main
    channels = get_available_channels(OPTIONS.user, OPTIONS.password)
  File "/sbin/rhn-channel", line 95, in get_available_channels
    modified_servers.append(urlparse.urlunsplit(scheme, netloc, '/rpc/api', query, fragment))
<type 'exceptions.TypeError'>: urlunsplit() takes exactly 1 argument (5 given)

It may be that the expected input for urlunsplit has changed in newer versions of python.

Aldy, can you tell us what the output of 'rpm -q python' is and if you see the error above in /var/log/up2date?
Comment 6 RHEL Product and Program Management 2012-12-14 03:15:22 EST
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.

Note You need to log in before you can comment on or make changes to this bug.