Bug 848915 - slpd runs as initrc_t
slpd runs as initrc_t
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: selinux-policy (Show other bugs)
6.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: Miroslav Grepl
Milos Malik
:
Depends On:
Blocks: 832330 870600
  Show dependency treegraph
 
Reported: 2012-08-16 15:23 EDT by Milos Malik
Modified: 2013-02-21 03:27 EST (History)
1 user (show)

See Also:
Fixed In Version: selinux-policy-3.7.19-160.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 870600 (view as bug list)
Environment:
Last Closed: 2013-02-21 03:27:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milos Malik 2012-08-16 15:23:14 EDT
Description of problem:


Version-Release number of selected component (if applicable):
selinux-policy-mls-3.7.19-155.el6_3.1.noarch
selinux-policy-3.7.19-155.el6_3.1.noarch
selinux-policy-minimum-3.7.19-155.el6_3.1.noarch
selinux-policy-doc-3.7.19-155.el6_3.1.noarch
selinux-policy-targeted-3.7.19-155.el6_3.1.noarch
openslp-server-2.0-0.2.beta2.el6.i686

How reproducible:
always

Steps to Reproduce:
# run_init service slpd status
Authenticating root.
Password: 
slpd is stopped
# run_init service slpd start
Authenticating root.
Password: 
Starting slpd: Multicast Route Enabled                     [  OK  ]
# ps -efZ | grep slpd
system_u:system_r:initrc_t:s0   daemon    3634     1  0 21:18 ?        00:00:00 /usr/sbin/slpd
unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 root 3637 1972  0 21:18 pts/0 00:00:00 grep slpd
#
  
Actual results:
 * slpd runs as initrc_t

Expected results:
 * slpd runs in its own SELinux domain
Comment 3 errata-xmlrpc 2013-02-21 03:27:43 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0314.html

Note You need to log in before you can comment on or make changes to this bug.