Bug 848918 - sensord runs as initrc_t
sensord runs as initrc_t
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: selinux-policy (Show other bugs)
6.3
All Linux
unspecified Severity medium
: rc
: ---
Assigned To: Miroslav Grepl
Milos Malik
:
Depends On:
Blocks: 832330 870599
  Show dependency treegraph
 
Reported: 2012-08-16 15:41 EDT by Milos Malik
Modified: 2013-02-21 03:27 EST (History)
2 users (show)

See Also:
Fixed In Version: selinux-policy-3.7.19-160.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 870599 (view as bug list)
Environment:
Last Closed: 2013-02-21 03:27:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milos Malik 2012-08-16 15:41:22 EDT
Description of problem:


Version-Release number of selected component (if applicable):
selinux-policy-mls-3.7.19-155.el6_3.1.noarch
selinux-policy-3.7.19-155.el6_3.1.noarch
selinux-policy-minimum-3.7.19-155.el6_3.1.noarch
selinux-policy-doc-3.7.19-155.el6_3.1.noarch
selinux-policy-targeted-3.7.19-155.el6_3.1.noarch
lm_sensors-sensord-3.1.1-10.el6.i686

How reproducible:
always

Steps to Reproduce:
# run_init service sensord status
Authenticating root.
Password: 
sensord is stopped
No sensors found!
Make sure you loaded all the kernel drivers you need.
Try sensors-detect to find out which these are.
# run_init service sensord start
Authenticating root.
Password: 
Starting sensord:                                          [  OK  ]
# ps -efZ | grep sensord
system_u:system_r:initrc_t:s0   root      3907     1  0 21:39 ?        00:00:00 sensord -i 1m -l 20m -f daemon
unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 root 3910 1972  0 21:39 pts/0 00:00:00 grep sensord
#
  
Actual results:
 * sensord runs as initrc_t

Expected results:
 * sensord runs in its own SELinux domain
Comment 4 errata-xmlrpc 2013-02-21 03:27:46 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0314.html

Note You need to log in before you can comment on or make changes to this bug.