Bug 84892 - up2date throws error: "File Not Found: r-e-d.a"
up2date throws error: "File Not Found: r-e-d.a"
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-02-23 00:48 EST by Max McAllister
Modified: 2007-04-18 12:51 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-26 20:31:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Max McAllister 2003-02-23 00:48:05 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
While retrieving package kernel-uml-2.4.18-19.8.0i686.rpm, the following error
appears repeatedly and halts the upgrade:


There was a fatal error communicating with the server.  The message was:
File Not Found: r-e-d.a

Error Message:
    Package not found
Error Class Code: 17
Error Class Info: File not found.
Explanation: 
     An error has occurred while processing your request. If this problem
     persists please submit a bug report to rhn-help@redhat.com.
     If you choose to submit the bug report, please be sure to include
     details of what you were trying to do when this error occurred and
     details on how to reproduce this problem.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
This is the first update since installation of RedHat Linux Pro 8.0.
1.Red exclamation ball in system tray.
2.Execute up2date.
3.180 files reprted as needing to be updated.
4.All kernel files are reported as not flagged for update.
5.All kernal files are selected and Forward button is pushed.
6.All 180 files are selected and Forward buton is pushed.
7.RPM interdepencies are resolved and packages are being retrieved.
8.Error box appears. 
    

Actual Results:  Pressed OK button and stop.

Expected Results:  Software updates complete.

Additional info:

Following error appears repeatedly and halts the upgrade:

There was a fatal error communicating with the server.  The message was:
File Not Found: r-e-d.a

Error Message:
    Package not found
Error Class Code: 17
Error Class Info: File not found.
Explanation: 
     An error has occurred while processing your request. If this problem
     persists please submit a bug report to rhn-help@redhat.com.
     If you choose to submit the bug report, please be sure to include
     details of what you were trying to do when this error occurred and
     details on how to reproduce this problem.
Comment 1 Need Real Name 2003-03-22 16:50:30 EST
I have the same problem. So I tried to update the kernel one at a time and was 
left with the update to kernel-uml 2.4.18-19.8.0 which causes the r-e-d.a file 
not found bug.
Comment 2 David McCaffrey 2003-06-26 09:48:56 EDT
I have also gotten this error and got past it by excluding 
kernel-uml 2.4.18-19.8.0
Comment 3 Joel Rybolt 2003-06-28 14:44:41 EDT
I have the same situation as David McCaffrey in comment #2.  I skipped the
kernel-uml 2.4.18-19.8.0 and completed the rest of the updates.  The Alert
Notification Tool says I still need to download this but all the other updates
are installed and working so I am just ignoring it.  I would appreciated being
notified when/if this is fixed.
Comment 4 Ash 2003-08-05 08:51:00 EDT
Hi
  I have installed RH 9 and had a similar problem with the
gtkhtml-1.1.9-0.9.src.rpm - I have made a similar adjustment to the download as
per comment 3 but I would like a fix.

Thanks

Ash
Comment 5 Adrian Likins 2003-08-06 19:20:10 EDT
This typically indicates a server error. There were
a few src rpms that went missing from the server that
should now be fixed.
Comment 6 Ryan Starret 2004-02-07 13:32:34 EST
Having the same problem with redhat 9 with the following packages...

gdm, krb5-devel, krb5-libs, mutt, nfs-utils, perl...

I've given up at this point.  Any fix would be appreciated.
Comment 7 jkossatz 2004-02-10 04:52:51 EST
I had the samr problem with RedHat 9 while trying to update
tcltk-8.3.5-88.src.rpm

There was a fatal error communicating with the server.  The message was:
File Not Found: r-e-d.a

Error Message:
    Invalid RPM package tcltk-8.3.5-88.src.rpm requested
Error Class Code: 17
Error Class Info: File not found.
Explanation: 
     An error has occurred while processing your request. If this problem
     persists please enter a bug report at bugzilla.redhat.com.
     If you choose to submit the bug report, please be sure to include
     details of what you were trying to do when this error occurred and
     details on how to reproduce this problem.
Comment 8 glmiller 2004-02-14 00:23:34 EST
I've had the same problems as in comment #7 except for a considerable
number of files.  The last to fail was gdm-2.4.1.3-5.1.src.rpm.  Prior
to that was anything related to php, up2date, bash, and so on.  After
spending untold number of hours I finally gave up.  
Comment 9 Frank C. Barden, Jr. 2004-05-10 10:37:04 EDT
fbarden@4netpros.com
Comment 10 Todd Warner 2004-08-26 20:31:03 EDT
RHL 9 (unsupported)

Note You need to log in before you can comment on or make changes to this bug.