Bug 84893 - prelink .rpm belongs in Workstation install
prelink .rpm belongs in Workstation install
Status: CLOSED NOTABUG
Product: Red Hat Public Beta
Classification: Retired
Component: comps (Show other bugs)
phoebe
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Powers
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-02-23 00:58 EST by John Reiser
Modified: 2007-04-18 12:51 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-23 07:35:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Reiser 2003-02-23 00:58:05 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020529

Description of problem:
The prelink .rpm is not installed for a Workstation install (software
development) on i686, but it should be.  For instance, prelink is a prerequisite
for rebuilding glibc-2.3.1-46.src.rpm for target i686.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install phoebe (RHL 8.0.94) Workstation configuration on i686.
2.Download and install glibc-2.3.1-46.src.rpm.
3.Try to rebuild with "rpmbuild -bc --target i686 glibc.spec".
    

Actual Results:  rpmbuild fails; missing prerequisites:
    /usr/bin/readlink
    prelink >= 0.0.2-5

Expected Results:  Workstation configuration should be enough to rebuild any
.rpm, including for i686.

Additional info:
Comment 1 Tim Powers 2003-02-23 07:35:57 EST
Actually, the assumption that a workstation install should be enough to build
any package  is incorrect. The only way to guarantee everything will be built is
to perform an install of "everything". 

Not all packages are in the comps file, only the packages that the majority of
users use. Just because a componenet has  "development" in the name doesn't mean
that you will be able to build all of the packages in the distro. In other
words, comps is meant for installtime deps, not buildtime.

Note You need to log in before you can comment on or make changes to this bug.