Bug 848930 - X will not start up in Fedora 18 KVM guests with cirrus video adapter
X will not start up in Fedora 18 KVM guests with cirrus video adapter
Product: Fedora
Classification: Fedora
Component: comps (Show other bugs)
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Bill Nottingham
Depends On:
Blocks: F18Beta/F18BetaBlocker
  Show dependency treegraph
Reported: 2012-08-16 16:44 EDT by Adam Williamson
Modified: 2014-03-16 23:31 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2012-08-17 10:17:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Adam Williamson 2012-08-16 16:44:42 EDT
If you set the video adapter in a KVM guest to 'cirrus', then try and boot any Fedora 18 image we've tried, X fails to start up. 'grep EE /var/log/Xorg.0.log' shows:

[   159.228] (EE) Failed to load module "modesetting" (module does not exist, 0)
[   159.245] (EE) cirrus: The PCI device 0xb8 at 00@00:02:0 has a kernel module claiming it.
[   159.245] (EE) cirrus: This driver cannot operate until it has been unloaded.
[   159.253] (EE) No devices detected.
[   159.253] (EE) 
[   159.253] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[   159.253] (EE)

I'd provide more detailed logs, but ajax says he knows about this issue already, I'm just filing the bug for tracking purposes. Proposing as a potential Beta blocker per criterion "The release must be able host virtual guest instances of the same release, using Fedora's current preferred virtualization technology", as this is basically virt-specific (we care not at all about real cirrus hardware any more). Note that qxl is also broken - I'll file a bug for that - so right now you have to go with 'vga' to get a VM to boot F18. Very slowly.
Comment 1 Adam Williamson 2012-08-16 16:46:23 EDT
Oh, booting with 'nomodeset' does work (airlied asked about that).
Comment 2 Adam Williamson 2012-08-16 17:10:31 EDT
So, the problem here really is that we don't want to be using the cirrus driver any more, we want to be using the 'modesetting' driver. So we need to add that to F18 comps to make sure it gets used.
Comment 3 Bill Nottingham 2012-08-17 10:17:30 EDT
This was done.
Comment 4 Adam Williamson 2012-08-17 15:43:03 EDT
Note: I think this didn't make TC3 because it was built too soon after the comps change (so there hadn't been a new mash), but it should make TC4/RC1/whatever the next build is.
Comment 5 Reartes Guillermo 2012-08-19 13:17:05 EDT
I tried F18 TC3 with KVM-> VNC/CIRRUS under F17 (a pre existing btrfs testing guest) and the result is a black screen.

However, it boots in basic video mode under troubleshooting. Then i encounter some other unrelated issue.
Comment 6 Reartes Guillermo 2012-08-19 15:56:57 EDT
> Oh, booting with 'nomodeset' does work (airlied asked about that).
yes it does work for me.

After more testing, suddenly the F13 TC3 started to fall back to text mode. Before that, it was just a black screen. Now i do not get a black screen witch vnc/cirrus but the text mode instead.

Strangely, that black screen happens also with spice/qlx in another guest, so maybe there is an additional issue or something different.
Comment 7 Adam Williamson 2012-08-20 19:02:06 EDT
reartes: see comment #4. the fix did not make TC3.

the qxl issue is a different bug, #844463.
Comment 8 Pádraig Brady 2012-09-13 04:30:50 EDT
FYI cirrus still an issue in RC3.
vga works fine

Note You need to log in before you can comment on or make changes to this bug.