Bug 849002 - dracut-initqueue errors while booting
dracut-initqueue errors while booting
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: dracut (Show other bugs)
18
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: dracut-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-16 23:35 EDT by Piruthiviraj Natarajan
Modified: 2013-05-29 10:21 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-29 09:24:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Piruthiviraj Natarajan 2012-08-16 23:35:02 EDT
I tried all the fedora 18 alpha images TC 1,2,3 x86_64 on USB thumb drive and I could not reach beyond emergency shell.

The screen shows 
dracut-initqueue[305]:mount no media found on /dev/sr0
dracut-initqueue[305]:warning couldn't mount /dev/sr0
dracut-initqueue[305]:warning no suitable image
dracut-initqueue[305]:warning could not boot
dracut-initqueue[305]:warning /dev/root doesnt not exist.

and ends with a dracut shell prompt.

The image cannot boot into xorg whatsoever.
I didn't find anyone posting this error so I filed a new bug.

If you need anything more I here to help.
Comment 1 Harald Hoyer 2012-08-17 10:37:39 EDT
sr0 ?? What is the kernel command line?
Comment 2 Piruthiviraj Natarajan 2012-08-17 11:12:02 EDT
vmlinuz initrd=initrd.img quiet rd.live.check

This is all I have on my kernel command line. fedora 17 had a longer kernel command line.
Comment 3 Piruthiviraj Natarajan 2012-08-31 13:30:28 EDT
I tested F18 TC4 image too. Same errors on USB install. why not this bug qualify as an Alpha blocker?
Comment 4 Jens Petersen 2012-11-06 21:26:15 EST
How did you write the iso to usb?
Comment 5 Piruthiviraj Natarajan 2012-11-06 21:35:03 EST
I used dd.
Comment 6 Harald Hoyer 2012-11-29 10:28:41 EST
you should use "livecd-iso-to-disk" rather than "dd" for that.
Comment 7 Piruthiviraj Natarajan 2012-11-29 10:47:12 EST
well this bug has become obsolete becoz of the numerous changes that happened meanwhile in Anaconda.

Now everything works fine. 
@ harald 

Why would you recommend to use livecd-iso-to-disk when we already have a dd which does the job perfectly?
Comment 8 Harald Hoyer 2012-11-30 02:38:11 EST
(In reply to comment #7)
> well this bug has become obsolete becoz of the numerous changes that
> happened meanwhile in Anaconda.
> 
> Now everything works fine. 

ok, then you can close it.

> @ harald 
> 
> Why would you recommend to use livecd-iso-to-disk when we already have a dd
> which does the job perfectly?

Hmm, because I would think, that "livecd-iso-to-disk" is not just "dd", and to rule out other human errors, I suggest to use it.

Note You need to log in before you can comment on or make changes to this bug.