Bug 849038 - core_pattern do not resolve the symbol %e with process name after reboot
core_pattern do not resolve the symbol %e with process name after reboot
Status: CLOSED DUPLICATE of bug 851097
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: abrt (Show other bugs)
6.2
x86_64 Linux
unspecified Severity medium
: rc
: ---
Assigned To: Denys Vlasenko
qe-baseos-tools
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-17 03:05 EDT by prashant ingale
Modified: 2013-03-01 00:08 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-23 10:00:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description prashant ingale 2012-08-17 03:05:52 EDT
Description of problem:

*After updating the Core pattern (file /proc/sys/kernel/core_pattern) with core.%p.%u.%e.%t. %e symbol do not resolve 

Version-Release number of selected component (if applicable):
abrt-2.0.8-6.el6.x86_64

How reproducible:


Steps to Reproduce:
1. Upadte  /etc/sysctl.conf
========
fs.suid_dumpable = 1
kernel.core_pattern = core.%p.%u.%e.%t  
==========
  
2. Apply the above changes by using following command

# sysctl -p

3. Reboot the system and generate the core dump. then %e symbol will not resolved

e.g core.4260.70151.e.1343681356
  
Actual results:

core.4260.70151.e.1343681356

Expected results:

core.4260.70151.<Process name>.1343681356
Additional info:
Comment 2 Jiri Moskovcak 2012-08-22 08:52:41 EDT
    abrt-install-ccpp-hook: fix the check for %e presense. Closes rhbz#832085
    
    Signed-off-by: Denys Vlasenko <vda.linux@googlemail.com>
Comment 4 Jiri Moskovcak 2012-08-23 10:00:53 EDT

*** This bug has been marked as a duplicate of bug 851097 ***

Note You need to log in before you can comment on or make changes to this bug.