Bug 849064 - Fatal error: Exception down the road
Fatal error: Exception down the road
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: fedora-review (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Stanislav Ochotnicky
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-17 04:35 EDT by Matthieu Saulnier
Modified: 2012-12-20 10:59 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-20 10:59:11 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthieu Saulnier 2012-08-17 04:35:51 EDT
Description of problem:
Fedora-review doesn't work as expected. The review text file stay empty after a run.

Version-Release number of selected component (if applicable):
fedora-review-0.2.2-1.fc17.noarch

How reproducible:
Always

Steps to Reproduce:
1. $ fedora-review -v -u https://bugzilla.redhat.com/show_bug.cgi?id=739367
2. watch it crashing
3.
  
Actual results:
[builder@Blackbird ~]$ fedora-review -v -u https://bugzilla.redhat.com/show_bug.cgi?id=739367
Processing bug on url: https://bugzilla.redhat.com/show_bug.cgi?id=739367
Getting .spec and .srpm Urls from : https://bugzilla.redhat.com/show_bug.cgi?id=739367
Active settings after processing options
    resultdir: None
    verbose: True
    no_report: False
    list_checks: False
    single: None
    rpm_spec: False
    exclude: None
    ext_dirs: /home/builder/.config/fedora-review/plugins:/usr/share/fedora-review/plugins:%s
    log_level: 10
    init_done: True
    cache: False
    mock_config: None
    version: False
    _log_config_done: True
    bz_url: https://bugzilla.redhat.com
    mock_options: --no-cleanup-after
    other_bz: None
    user: None
    bug: None
    prebuilt: False
    name: None
    url: https://bugzilla.redhat.com/show_bug.cgi?id=739367
    checksum: sha256
    nobuild: False
    _con_handler: <logging.StreamHandler object at 0x24ed2d0>
    login: False
    assign: False
  --> SRPM url: http://rpms.famillecollet.com/SRPMS/php-pecl-mysqlnd-qc-1.1.1-1.remi.src.rpm
  --> Spec url: https://raw.github.com/remicollet/remirepo/master/php/pecl/php-pecl-mysqlnd-qc/php-pecl-mysqlnd-qc.spec
Using review directory: /home/builder/php-pecl-mysqlnd-qc
Downloading .spec and .srpm files
  --> /home/builder/php-pecl-mysqlnd-qc/upstream : http://pecl.php.net/get/mysqlnd_qc-1.1.1.tgz
Downloading (Source0): http://pecl.php.net/get/mysqlnd_qc-1.1.1.tgz
No upstream for (Source1): mysqlnd_qc.ini
Add module: CheckAddMavenDepmap
Add module: CheckBundledJars
Add module: CheckJPackageRequires
Add module: CheckJavaFullVerReqSub
Add module: CheckJavadoc
Add module: CheckJavadocJPackageRequires
Add module: CheckJavadocdirName
Add module: CheckLocalDepmap
Add module: CheckNoArch
Add module: CheckNoOldMavenDepmap
Add module: CheckNoRequiresPost
Add module: CheckNotJavaApplicable
Add module: CheckPomInstalled
Add module: CheckTestSkip
Add module: CheckUpdateDepmap
Add module: CheckUpstremBuildMethod
Add module: CheckUseMavenpomdirMacro
Add module: GemCheckDoesntHaveNonGemSubpackage
Add module: GemCheckExcludesGemCache
Add module: GemCheckFilePlacement
Add module: GemCheckProperName
Add module: GemCheckRequiresProperDevel
Add module: GemCheckSetsGemName
Add module: GemCheckUsesMacros
Add module: NonGemCheckFilePlacement
Add module: NonGemCheckRequiresProperDevel
Add module: NonGemCheckUsesMacros
Add module: RubyCheckBuildArchitecture
Add module: RubyCheckPlatformSpecificFilePlacement
Add module: RubyCheckRequiresRubyAbi
Add module: RubyCheckTestsNotRunByRake
Add module: RubyCheckTestsRun
Add module: CheckApprovedLicense
Add module: CheckBuild
Add module: CheckBuildCompilerFlags
Add module: CheckBuildInMock
Add module: CheckBuildRequires
Add module: CheckBuildroot
Add module: CheckBundledLibs
Add module: CheckChangelogFormat
Add module: CheckClean
Add module: CheckCodeAndContent
Add module: CheckConfigNoReplace
Add module: CheckContainsLicenseText
Add module: CheckDefattr
Add module: CheckDescMacroes
Add module: CheckDesktopFile
Add module: CheckDesktopFileInstall
Add module: CheckDevelFilesInDevel
Add module: CheckDirectoryRequire
Add module: CheckDistTag
Add module: CheckDocRuntime
Add module: CheckExcludeArch
Add module: CheckFilePermissions
Add module: CheckFileRequires
Add module: CheckFilesDuplicates
Add module: CheckFinalRequiresProvides
Add module: CheckFullVerReqSub
Add module: CheckFunctionAsDescribed
Add module: CheckGuidelines
Add module: CheckIllegalSpecTags
Add module: CheckInstall
Add module: CheckLargeDocs
Add module: CheckLatestVersionIsPackaged
Add module: CheckLicensInDoc
Add module: CheckLicenseField
Add module: CheckLicenseInSubpackages
Add module: CheckLicenseUpstream
Add module: CheckLocale
Add module: CheckMacros
Add module: CheckMakeinstall
Add module: CheckManPages
Add module: CheckMultipleLicenses
Add module: CheckNameCharset
Add module: CheckNaming
Add module: CheckNoConfigInUsr
Add module: CheckNoConflicts
Add module: CheckObeysFHS
Add module: CheckObsoletesForRename
Add module: CheckOwnDirs
Add module: CheckOwnOther
Add module: CheckPackageInstalls
Add module: CheckParallelMake
Add module: CheckPatchComments
Add module: CheckPkgConfigFiles
Add module: CheckRelocatable
Add module: CheckReqPkgConfig
Add module: CheckRequires
Add module: CheckRpmLint
Add module: CheckRpmLintInstalled
Add module: CheckScriptletSanity
Add module: CheckSourceComment
Add module: CheckSourceMD5
Add module: CheckSourcePatchPrefix
Add module: CheckSourceUrl
Add module: CheckSpecAsInSRPM
Add module: CheckSpecDescTranlation
Add module: CheckSpecLegibility
Add module: CheckSpecName
Add module: CheckSupportAllArchs
Add module: CheckSystemdScripts
Add module: CheckTestSuites
Add module: CheckTimeStamps
Add module: CheckUTF8Filenames
Add module: CheckUseGlobal
Add module: CheckUsefulDebuginfo
Add module: PhpCheckPhpRequire
Add module: SugarActivityCheckBuildRequires
Add module: SugarActivityCheckNaming
Add module: SugarActivityCheckRuntimeDeps
Add module: CheckHeaderFiles
Add module: CheckLDConfig
Add module: CheckLibToolArchives
Add module: CheckNoKernelModules
Add module: CheckNoStaticExecutables
Add module: CheckRPATH
Add module: CheckSoFiles
Add module: CheckStaticLibs
Add module: RCheckBuildRequires
Add module: RCheckBuildSection
Add module: RCheckCheckMacro
Add module: RCheckDir
Add module: RCheckDoc
Add module: RCheckLatestVersionIsPackaged
Add module: RCheckRequires
Running checks and generate report

Rebuilding /home/builder/php-pecl-mysqlnd-qc/srpm/php-pecl-mysqlnd-qc-1.1.1-1.remi.src.rpm using default root
Mock command: mock --rebuild --no-cleanup-after --resultdir=/home/builder/php-pecl-mysqlnd-qc/results  /home/builder/php-pecl-mysqlnd-qc/srpm/php-pecl-mysqlnd-qc-1.1.1-1.remi.src.rpm 2>&1 | tee build.log
INFO: mock.py version 1.1.26 starting...
Start: init plugins
INFO: selinux enabled
Finish: init plugins
Start: run
INFO: Start(/home/builder/php-pecl-mysqlnd-qc/srpm/php-pecl-mysqlnd-qc-1.1.1-1.remi.src.rpm)  Config(fedora-17-x86_64)
Start: lock buildroot
Start: clean chroot
INFO: chroot (/dev/shm/fedora-17-x86_64) unlocked and deleted
Finish: clean chroot
Finish: lock buildroot
Start: chroot init
Start: lock buildroot
Mock Version: 1.1.26
INFO: Mock Version: 1.1.26
INFO: calling preinit hooks
INFO: enabled root cache
Start: unpacking root cache
Finish: unpacking root cache
INFO: enabled yum cache
Start: cleaning yum metadata
Finish: cleaning yum metadata
INFO: enabled ccache
Start: device setup
Finish: device setup
Start: yum update
Finish: yum update
Finish: lock buildroot
Finish: chroot init
INFO: Installed packages:
Start: build phase for php-pecl-mysqlnd-qc-1.1.1-1.remi.src.rpm
Start: device setup
Finish: device setup
Start: build setup for php-pecl-mysqlnd-qc-1.1.1-1.remi.src.rpm
Finish: build setup for php-pecl-mysqlnd-qc-1.1.1-1.remi.src.rpm
Start: rpmbuild -bb php-pecl-mysqlnd-qc-1.1.1-1.remi.src.rpm
Finish: rpmbuild -bb php-pecl-mysqlnd-qc-1.1.1-1.remi.src.rpm
Finish: build phase for php-pecl-mysqlnd-qc-1.1.1-1.remi.src.rpm
INFO: Done(/home/builder/php-pecl-mysqlnd-qc/srpm/php-pecl-mysqlnd-qc-1.1.1-1.remi.src.rpm) Config(default) 0 minutes 33 seconds
INFO: Results and/or logs in: /home/builder/php-pecl-mysqlnd-qc/results
Finish: run
Exception down the road...
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/FedoraReview/review_helper.py", line 130, in run
    self.__do_report()
  File "/usr/lib/python2.7/site-packages/FedoraReview/review_helper.py", line 81, in __do_report
    self.__run_checks(self.bug.spec_file, self.bug.srpm_file)
  File "/usr/lib/python2.7/site-packages/FedoraReview/review_helper.py", line 102, in __run_checks
    writedown=not Settings.no_report)
  File "/usr/lib/python2.7/site-packages/FedoraReview/checks_class.py", line 176, in run_checks
    if test.is_applicable():
  File "/usr/lib/python2.7/site-packages/FedoraReview/checks/java.py", line 242, in is_applicable
    return self.has_files("*.pom")
  File "/usr/lib/python2.7/site-packages/FedoraReview/check_base.py", line 113, in has_files
    rpm_files = self.srpm.get_files_rpms()
  File "/usr/lib/python2.7/site-packages/FedoraReview/srpm_file.py", line 241, in get_files_rpms
    self.build()
  File "/usr/lib/python2.7/site-packages/FedoraReview/srpm_file.py", line 116, in build
    return self.mockbuild(force)
  File "/usr/lib/python2.7/site-packages/FedoraReview/srpm_file.py", line 143, in mockbuild
    Mock.builddir_cleanup()
  File "/usr/lib/python2.7/site-packages/FedoraReview/mock.py", line 232, in builddir_cleanup
    paths = glob(os.path.join(self.get_builddir('BUILD'), '*'))
  File "/usr/lib/python2.7/site-packages/FedoraReview/mock.py", line 86, in get_builddir
    p = self._get_dir('root/builddir/build')
  File "/usr/lib/python2.7/site-packages/FedoraReview/mock.py", line 64, in _get_dir
    self._get_root()
  File "/usr/lib/python2.7/site-packages/FedoraReview/mock.py", line 59, in _get_root
    exec config
  File "<string>", line 7, in <module>
KeyError: 'plugin_conf'
Exception down the road...


Expected results:
Works as expected


Additional info:
Comment 1 Stanislav Ochotnicky 2012-08-17 05:26:00 EDT
Fixed in upstream git commit 4664a8a. Will be in next release. Thanks for the bugreport
Comment 2 Stanislav Ochotnicky 2012-08-17 05:28:36 EDT
For the record, issue is with using nested mock config. Simplifying your mock configuration should be a nice workaround until we release a new version
Comment 3 Matthieu Saulnier 2012-08-17 07:52:01 EDT
Thanks a lot.
Comment 4 Matthieu Saulnier 2012-09-17 17:37:50 EDT
Ping ?
No update scheduled ?
Comment 5 Stanislav Ochotnicky 2012-09-18 04:39:28 EDT
Yes, we are preparing new release, but it will take a few more days since we had more changes planned
Comment 6 Fedora Update System 2012-09-24 10:59:00 EDT
fedora-review-0.3.0-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/fedora-review-0.3.0-1.fc16
Comment 7 Fedora Update System 2012-09-24 11:02:36 EDT
fedora-review-0.3.0-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/fedora-review-0.3.0-1.fc17
Comment 8 Fedora Update System 2012-09-24 11:03:20 EDT
fedora-review-0.3.0-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/fedora-review-0.3.0-1.fc18
Comment 9 Fedora Update System 2012-09-24 16:01:19 EDT
Package fedora-review-0.3.0-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing fedora-review-0.3.0-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-14663/fedora-review-0.3.0-1.fc18
then log in and leave karma (feedback).
Comment 10 Fedora Update System 2012-12-20 10:59:13 EST
fedora-review-0.3.0-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.