This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 849071 - hp3-sendfax caused denial, dbus + hplip
hp3-sendfax caused denial, dbus + hplip
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: selinux-policy (Show other bugs)
5.9
All Linux
medium Severity medium
: rc
: ---
Assigned To: Miroslav Grepl
Milos Malik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-17 04:48 EDT by Petr Sklenar
Modified: 2013-01-07 22:33 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 22:33:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Petr Sklenar 2012-08-17 04:48:59 EDT
Description of problem:
hp3-sendfax causes denial when accessing file to be faxed

Version-Release number of selected component (if applicable):
# rpm -q cups hplip3 selinux-policy
cups-1.3.7-30.el5
hplip3-3.9.8-14.el5
selinux-policy-2.4.6-327.el5


How reproducible:
deterministic

Steps to Reproduce:
1. as a user, use graphical hp3-sendfax
2. add file to be faxed
  
Actual results:

type=USER_AVC msg=audit(1345193024.304:439): user pid=3524 uid=81 auid=4294967295 subj=system_u:system_r:system_dbusd_t:s0 msg='avc:  denied  { send_msg } for msgtype=signal interface=com.hplip.StatusService member=Event dest=org.freedesktop.DBus spid=17461 tpid=4635 scontext=user_u:system_r:hplip_t:s0-s0:c0.c1023 tcontext=user_u:system_r:unconfined_t:s0 tclass=dbus : exe="/bin/dbus-daemon" (sauid=81, hostname=?, addr=?, terminal=?)'
type=USER_AVC msg=audit(1345193024.304:440): user pid=3524 uid=81 auid=4294967295 subj=system_u:system_r:system_dbusd_t:s0 msg='avc:  denied  { send_msg } for msgtype=signal interface=com.hplip.StatusService member=Event dest=org.freedesktop.DBus spid=17461 tpid=4635 scontext=user_u:system_r:hplip_t:s0-s0:c0.c1023 tcontext=user_u:system_r:unconfined_t:s0 tclass=dbus : exe="/bin/dbus-daemon" (sauid=81, hostname=?, addr=?, terminal=?)'
type=USER_AVC msg=audit(1345193024.352:441): user pid=3524 uid=81 auid=4294967295 subj=system_u:system_r:system_dbusd_t:s0 msg='avc:  denied  { send_msg } for msgtype=signal interface=com.hplip.StatusService member=Event dest=org.freedesktop.DBus spid=17461 tpid=4635 scontext=user_u:system_r:hplip_t:s0-s0:c0.c1023 tcontext=user_u:system_r:unconfined_t:s0 tclass=dbus : exe="/bin/dbus-daemon" (sauid=81, hostname=?, addr=?, terminal=?)'

Expected results:
no denial

Additional info:
Comment 1 Milos Malik 2012-08-17 10:02:27 EDT
Could you retest the scenario with newer policy? Following policy already contains the fix.

# rpm -qa selinux\*
selinux-policy-minimum-2.4.6-331.el5
selinux-policy-devel-2.4.6-331.el5
selinux-policy-targeted-2.4.6-331.el5
selinux-policy-2.4.6-331.el5
selinux-policy-strict-2.4.6-331.el5
selinux-policy-mls-2.4.6-331.el5
# sesearch -s hplip_t -c dbus -p send_msg --allow -C
Found 4 av rules:
   allow hplip_t rpm_script_t : dbus send_msg ; 
   allow hplip_t hplip_t : dbus send_msg ; 
   allow hplip_t system_dbusd_t : dbus { acquire_svc send_msg }; 
   allow hplip_t unconfined_t : dbus send_msg ; 
#
Comment 2 RHEL Product and Program Management 2012-08-17 10:18:45 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 7 errata-xmlrpc 2013-01-07 22:33:13 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0060.html

Note You need to log in before you can comment on or make changes to this bug.