Bug 849112 - NoDisksError
NoDisksError
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
abrt_hash:37bd187fe75258feb6b49a6c148...
: CommonBugs
Depends On:
Blocks: F18Blocker/F18FinalBlocker
  Show dependency treegraph
 
Reported: 2012-08-17 07:05 EDT by Petr Schindler
Modified: 2012-11-15 09:35 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-15 09:35:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: program.log (31.18 KB, text/plain)
2012-08-17 07:05 EDT, Petr Schindler
no flags Details
File: environ (761 bytes, text/plain)
2012-08-17 07:05 EDT, Petr Schindler
no flags Details
File: type (9 bytes, text/plain)
2012-08-17 07:05 EDT, Petr Schindler
no flags Details
File: storage.log (66.39 KB, text/plain)
2012-08-17 07:05 EDT, Petr Schindler
no flags Details
File: release (24 bytes, text/plain)
2012-08-17 07:05 EDT, Petr Schindler
no flags Details
File: product (6 bytes, text/plain)
2012-08-17 07:05 EDT, Petr Schindler
no flags Details
File: anaconda.log (3.20 KB, text/plain)
2012-08-17 07:05 EDT, Petr Schindler
no flags Details
File: syslog (73.18 KB, text/plain)
2012-08-17 07:05 EDT, Petr Schindler
no flags Details
File: hashmarkername (8 bytes, text/plain)
2012-08-17 07:05 EDT, Petr Schindler
no flags Details
File: version (12 bytes, text/plain)
2012-08-17 07:05 EDT, Petr Schindler
no flags Details
File: anaconda-tb (175.83 KB, text/plain)
2012-08-17 07:05 EDT, Petr Schindler
no flags Details
File: description (551 bytes, text/plain)
2012-08-17 07:05 EDT, Petr Schindler
no flags Details

  None (edit)
Description Petr Schindler 2012-08-17 07:05:11 EDT
Description of problem:


Version-Release number of selected component:
anaconda-18.6

Additional info:
libreport version: 2.0.12
cmdline:        initrd=initrd.img  quiet rd.live.check BOOT_IMAGE=vmlinuz 
kernel:         3.6.0-0.rc1.git6.1.fc18.x86_64
Comment 1 Petr Schindler 2012-08-17 07:05:15 EDT
Created attachment 605166 [details]
File: program.log
Comment 2 Petr Schindler 2012-08-17 07:05:18 EDT
Created attachment 605167 [details]
File: environ
Comment 3 Petr Schindler 2012-08-17 07:05:20 EDT
Created attachment 605168 [details]
File: type
Comment 4 Petr Schindler 2012-08-17 07:05:22 EDT
Created attachment 605169 [details]
File: storage.log
Comment 5 Petr Schindler 2012-08-17 07:05:24 EDT
Created attachment 605170 [details]
File: release
Comment 6 Petr Schindler 2012-08-17 07:05:26 EDT
Created attachment 605171 [details]
File: product
Comment 7 Petr Schindler 2012-08-17 07:05:28 EDT
Created attachment 605172 [details]
File: anaconda.log
Comment 8 Petr Schindler 2012-08-17 07:05:30 EDT
Created attachment 605173 [details]
File: syslog
Comment 9 Petr Schindler 2012-08-17 07:05:33 EDT
Created attachment 605174 [details]
File: hashmarkername
Comment 10 Petr Schindler 2012-08-17 07:05:35 EDT
Created attachment 605175 [details]
File: version
Comment 11 Petr Schindler 2012-08-17 07:05:37 EDT
Created attachment 605176 [details]
File: anaconda-tb
Comment 12 Petr Schindler 2012-08-17 07:05:39 EDT
Created attachment 605177 [details]
File: description
Comment 13 Petr Schindler 2012-08-17 07:32:20 EDT
How to reproduce:

1. In main hub choose Installation destination
2. Choose disk and click on continue
3. Choose to review setting and continue
4. Choose to create mounting points automaticaly

I propose this as alpha blocker, due to criterion:
"The installer must be able to complete an installation using the entire disk, existing free space, or existing Linux partitions methods, with or without encryption or LVM enabled "
Comment 14 Kamil Páral 2012-08-17 07:44:13 EDT
The traceback:

anaconda 18.6 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/partitioning.py", line 290, in doAutoPartition
    raise NoDisksError
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 755, in _do_autopart
    doAutoPartition(self.__storage, self.data)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 763, in on_create_clicked
    self._do_autopart()
NoDisksError
Comment 15 David Lehman 2012-08-17 10:13:17 EDT
We'll be adding some better error messaging soon, but the procedure you have followed will continue to not work. You have to remove the existing devices from your disk to make room for the automatically-created layout.
Comment 16 Adam Williamson 2012-08-20 19:29:44 EDT
Discussed at 2012-08-20 QA meeting, acting as a blocker review meeting: http://meetbot.fedoraproject.org/fedora-meeting/2012-08-20/fedora-qa.2012-08-20-15.00.html . Accepted as a Final blocker per criterion "The installer must be able to create and install to any workable partition layout using any file system offered in a default installer configuration, LVM, software, hardware or BIOS RAID, or combination of the above"; the Alpha and Beta criteria are too tight for this to constitute an earlier blocker. As dlehman wrote, this isn't actually expected to work as described in comment #13, but anaconda should not crash.

Note that, effectively, the 'review layout' button in newUI just puts you straight into custom partitioning mode; in oldUI, it did automatic partitioning for you and then went into custom partitioning mode to show you the results of the automatic partitioning and let you adjust them if necessary. The anaconda team agrees that it's a bad idea to include a UI element in newUI that looks very similar to one from oldUI but has significantly different effects; they'll look at ways of improving on this so the behaviour isn't a surprise.
Comment 17 John Reiser 2012-09-03 13:23:28 EDT
In anaconda-18.6.4 (as on Fedora 18-Alpha-TC5) another way to get the crash with NoDisksError traceback is to click Back from the Storage Selection spoke without making any changes, selections, or buttons other than Back.  Thus you cannot see what is on the Storage Selection spoke, then change you mind and go back "non-destructively".  Instead, upon getting back to the Hub then having no destination selected should not be fatal.  This is merely going back to the same state as before clicking on Storage Selection.

-----anaconda-tb-...
anaconda 18.6.4 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/pyanaconda/storage/partitioning.py", line 276, in doAutoPartition
    raise NoDisksError
  File "/usr/lib/python2.7/site-packages/pyanaconda/kickstart.py", line 260, in execute
    doAutoPartition(storage, ksdata)
  File "/usr/lib/python2.7/site-packages/pyanaconda/kickstart.py", line 1601, in doKickstartStorage
    ksdata.autopart.execute(storage, ksdata, instClass)
  File "/usr/lib/python2.7/site-packages/pyanaconda/ui/gui/spokes/storage.py", line 326, in execute
    doKickstartStorage(self.storage, self.data, self.instclass)
  File "/usr/lib/python2.7/site-packages/pyanaconda/ui/gui/hubs/__init__.py", line 107, in _runSpoke
    action.execute()
  File "/usr/lib/python2.7/site-packages/pyanaconda/ui/gui/hubs/__init__.py", line 317, in _on_spoke_clicked
    self._runSpoke(spoke)
NoDisksError
  [snip]
-----
Comment 18 Tao Wu 2012-09-04 04:52:47 EDT
I got this error by click the "Click here to create them automatically" on the "MANUAL PARRTITIONING", F18 alpha TC5 i386 in kvm.
Comment 19 Joachim Frieben 2012-09-07 05:33:56 EDT
Issue also occurs for anaconda-18.6.5-1.fc18.x86_64 after updating the installer of the Fedora 18 Alpha x86_64 TC5 live image.
Comment 20 David Lehman 2012-09-07 09:59:09 EDT
To be clear, there is no plan to change this for the alpha. It's too much new code to throw into the mix at this stage. You can expect nicer storage error handling in the first beta trees.
Comment 21 Adam Williamson 2012-09-11 15:12:11 EDT
We should certainly commonbugs this.
Comment 22 David Lehman 2012-11-15 09:35:41 EST
This should be handled in a way that does not halt the install as of the earliest F18 Beta trees.

Note You need to log in before you can comment on or make changes to this bug.