Bug 849134 - Package graphviz-gd shows Warning Could not load /usr/lib/graphviz/libgvplugin_gd.so.6
Summary: Package graphviz-gd shows Warning Could not load /usr/lib/graphviz/libgvplugi...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: graphviz
Version: 6.3
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: ---
Assignee: Jaroslav Škarvada
QA Contact: Miroslav Hradílek
URL:
Whiteboard:
Depends On:
Blocks: 857092
TreeView+ depends on / blocked
 
Reported: 2012-08-17 11:57 UTC by Miroslav Hradílek
Modified: 2012-09-19 10:17 UTC (History)
0 users

Fixed In Version: graphviz-2.26.0-10.el6
Doc Type: Bug Fix
Doc Text:
Previously there were printed several warnings during removal of graphviz-gd package. This was caused by "dot -c" command that was run in %postun scriptlet. This command recreates graphviz config files to be up-to-date with the current state of installed plugins. It tries to load plugins specified there and if it fails it prints warning. This behavior may be confusing thus the warnings were silenced.
Clone Of:
: 857092 (view as bug list)
Environment:
Last Closed: 2012-09-19 10:17:52 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:1291 normal SHIPPED_LIVE graphviz bug fix update 2012-09-19 14:16:30 UTC

Description Miroslav Hradílek 2012-08-17 11:57:21 UTC
Description of problem:

Package graphviz-gd shows Warning: Could not load "/usr/lib/graphviz/libgvplugin_gd.so.6

Version-Release number of selected component (if applicable):
graphviz-gd-2.26.0-7.el6.i686

How reproducible:
Always

Steps to Reproduce:
1. Install package and dependencies
2. Remove packages with "RPM -e"
  
Actual results:
Warning: Could not load "/usr/lib/graphviz/libgvplugin_gd.so.6" - file not found

Expected results:
Clean output

Comment 5 Jaroslav Škarvada 2012-08-17 17:56:38 UTC
Reproducer:
# yum install graphviz-gd
# rpm -e graphviz-gd

Comment 6 Jaroslav Škarvada 2012-08-17 17:56:38 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Previously there were printed several warnings during removal of graphviz-gd package. This was caused by "dot -c" command that was run in %postun scriptlet. This command recreates graphviz config files to be up-to-date with the current state of installed plugins. It tries to load plugins specified there and if it fails it prints warning. This behavior may be confusing thus the warnings were silenced.

Comment 10 errata-xmlrpc 2012-09-19 10:17:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-1291.html


Note You need to log in before you can comment on or make changes to this bug.