Bug 849138 - mandatory=core attribute in Export-Package header makes bundle unresolvable in Eclipse
mandatory=core attribute in Export-Package header makes bundle unresolvable i...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: lucene (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Alexander Kurtakov
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-17 08:02 EDT by Severin Gehwolf
Modified: 2013-03-01 04:24 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-01 04:24:03 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Severin Gehwolf 2012-08-17 08:02:35 EDT
Description of problem:
Any eclipse plug-in requiring org.apache.lucene.* packages fail to resolve due to mandatory=core attribute in Export-Package OSGi header.

Note that this is only an issue on F17 (F18, rawhide have fixed manifests)

Version-Release number of selected component (if applicable):
$ rpm -q lucene
lucene-2.9.4-8.fc17.noarch

How reproducible:
Always.

Steps to Reproduce:
1. Create Eclipse plug-in with Import-Package: org.apache.lucene.index
2. Attempt to run application
3. Plug-in fails to resolve
  
Actual results:
Resolution errors.

Expected results:
imported lucene packages should resolve

Additional info:
Removing 'mandadory=core' from the metadata in the manifest fixes this.
Comment 1 Alexander Kurtakov 2013-03-01 04:05:53 EST
Severin, is this fixed now? If not do you plan fixing it?
Comment 2 Alexander Kurtakov 2013-03-01 04:24:03 EST
Closing as wontfix as there seem to not be no need for this and I would rather prefer not playing with F17 and cause other potential rebuilds. Also the problem doesn't exist on F18 so interested parties should move.

Note You need to log in before you can comment on or make changes to this bug.