Bug 84914 - [Pensacola] Can't install AS2.1 on Yellowstone
[Pensacola] Can't install AS2.1 on Yellowstone
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: anaconda (Show other bugs)
2.1
All Linux
medium Severity high
: ---
: ---
Assigned To: Matt Wilson
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-02-23 15:23 EST by Larry Troan
Modified: 2016-04-18 05:39 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-14 15:32:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Larry Troan 2003-02-23 15:23:29 EST
A CD install of AS2.1 on Yellowstone fails. This system uses a USB cdrom and the
installer loads the usb-storage driver and detects the cdrom but when it passes
the type of media used for installation and if local CD-rom is picked, it asks
to insert RH AS2.1 cd and can\\\'t pass that window. In vt3, it says trying to
mound device scd0 repeatedly.
----------
Action by: tmichael
Issue Registered
----------
Action by: tmichael
Following the loading of drivers in vt4, usb-storage gets loaded, detecting all
usb devices, and is unloaded before loading any scsi drivers, thus disconnecting
the usb devices (cdrom in this case). Is there a way to force it to stay loaded?
I tried the scsi driver to be dependent on usb-storage by editing the
modules.dep in initrd but it didn't work.

Status set to: Waiting on Tech

----------
Action by: ltroan
NOTE FROM TESFAMARIAM....................
Any update on this?

Thanks,
Tesfamariam

-----Original Message-----
From: Michael, Tesfamariam 
Sent: Tuesday, January 28, 2003 3:18 PM
To: 'Larry Troan'
Cc: Kaisner, Dale; Matt Wilson
Subject: RE: AS2.1 installation help for Yellowstone


I created an issue tracker (#14777). What seems to happen is that,
usb-storage driver gets loaded and then before other scsi driver is loaded,
usb-storage is been unloaded, which mean no access to the usb-cdrom. Is
there a way to reloaded it again or keep it loaded from ks.cfg or somewhere?

If I choose a network install, once I get a shell, I can load the driver and
mount the cdrom but this wont help us since DSA can't do a network install,
it must use the cdrom.

Thanks,
Tesfamariam




----------
Action by: ltroan
Tesfamarian,

I checked with Michael Fulbright to confirm this is the same problem we
diagnosed when someone from Dell was trying to install AS on blades using a USB
CD-ROM for LinuxWorld. The answer is "yes, it is the same problem" and there are
no plans to respin anaconda before AS 3.0.
---
If you must install via USB CD-ROM, Michael suggests someone at Dell take the
Loader from a 7.3 anaconda and incorporate it on a CD with the other AS 2.1
anaconda code and packages. The problem was found and fixed in one of the 7.3
betas but was not backported to AS2.1.
---
The other alternative would be to do a net install (bootnet.img) via a USB
floppy and one of the board's EN NICs to a remote server... or via a PXE
installation.

Sorry I can't give you a better answer. 

Larry


Status set to: Waiting on Client

----------
Action by: tmichael
I already replaced the binary 'loader' file in initrd.img of AS2.1 in
dosutils/autoboot/initrd.img from RH8.0 but it was showing the say behavior. I
used the one from 8.0 since 8.0 is working ok with DSA and my configuration, let
me know if I must use the one in 7.3.
I have done a few network installs but since I am trying to find a solution for
DSA, a local CD must be used. Any work-around is appreciated.

Thanks,
Tesfamariam

Status set to: Waiting on Tech

----------
Action by: msw
please test images at http://people.redhat.com/msw/bladecenter/  -- these images
should address your problems.



----------
Action by: ltroan
Talked with Matt Wilson and there are two scenarios here to resolve the problem:
1) The simplier for RH is to use the floppy on the msw's bladecenter URL above
to boot and then plug in USB-CDROM.
2) If not acceptable, we will need to look at respinning CD#1 to include the new
initrd.img which fixed the basic problem on 7.3 and beyond.

tmichael assigned to issue for Dell-Engineering.
Status set to: Waiting on Client

----------
Action by: tmichael
Since the Shredder has only a single USB port and no usb-hub support from BIOS,
I don't think unplugging usb-floppy and plugging usb-cd in the middle of
installation is a good solution, at least for customer experience. Item 2 sounds
good but if the installation can be restricted for DSA only, We might just need
the new initrd.img with the fixes (no need to respin CD1 but give me the initrd
to verify).

Status set to: Waiting on Tech

----------
Action by: ltroan
NOTE FROM TMICHAEL...
Larry, when can I expect to have the initrd.img for this issue?

Thanks,
Tesfamariam


----------
Action by: ltroan
Tesfamariam,

Matt Wilson suggests you extract the initrd image from the boot disk on his
people page http://people.redhat.com/msw/bladecenter/AS-2.1-dd.img/. If this is
a problem, let me know and We'll extract it here and append it to this Issue
Tracker. 

Status set to: Waiting on Client

----------
Action by: tmichael
I extracted the files there but I can't replace our initrd.img since it has more
newer drivers such as megaraid and mptfusion. I am attaching the initrd.img we
use now, so you could make the changes to it or suggest what changes we should
make...


Status set to: Waiting on Tech
File uploaded: initrd21.img


ISSUE TRACKER 14777 opened by Dell as sev 1 - image needed for Yellowstone install.
Comment 1 Larry Troan 2003-02-23 15:28:44 EST
initrd21.img  attached to Issue Tracker 14777 -- too large to append to bugzilla. 
Comment 2 Michael Fulbright 2003-03-11 12:28:52 EST
Cleaned up summary line from strange characters.
Comment 3 Suzanne Hillman 2003-08-14 15:32:05 EDT
The issue tracker to which this was attached has been closed by client, as of
03-06-2003 07:13pm. Closing this. I'm not entirely sure 'Currentrelease' is
totally accurate, but none of the other options even seem to come close...

Note You need to log in before you can comment on or make changes to this bug.